Additional renaming of kde to tde

pull/1/head
Timothy Pearson 11 years ago
parent fbf4c6db00
commit dbec247f3c
  1. 8
      ChangeLog
  2. 122
      acinclude.m4
  3. 6
      amarok/amarok.kdevelop
  4. 2
      amarok/configure.in.in
  5. 2
      amarok/src/Options2.ui.h
  6. 2
      amarok/src/amarok.h
  7. 2
      amarok/src/amarokcore/crashhandler.cpp
  8. 2
      amarok/src/deletedialog.cpp
  9. 2
      amarok/src/filebrowser.cpp
  10. 2
      amarok/src/filebrowser.h
  11. 2
      amarok/src/magnatunebrowser/magnatunelistview.cpp
  12. 2
      amarok/src/mediadevice/daap/daapclient.h
  13. 2
      amarok/src/osd.cpp
  14. 2
      amarok/src/playlistbrowseritem.cpp
  15. 2
      amarok/src/playlistitem.cpp
  16. 2
      amarok/src/playlistwindow.cpp
  17. 2
      amarok/src/scripts/databasescripts/databaseScripts.rb
  18. 2
      amarok/src/statistics.cpp
  19. 2
      configure.in
  20. 2
      doc/amarok/advanced.docbook
  21. 2
      doc/da/advanced.docbook
  22. 2
      doc/de/advanced.docbook
  23. 2
      doc/es/advanced.docbook
  24. 2
      doc/et/advanced.docbook
  25. 2
      doc/it/advanced.docbook
  26. 2
      doc/nl/advanced.docbook
  27. 12
      doc/nl/faq.docbook
  28. 2
      doc/nl/quick.docbook
  29. 2
      doc/pl/advanced.docbook
  30. 2
      doc/pt/advanced.docbook
  31. 2
      doc/sv/advanced.docbook
  32. 2
      doc/sv/faq.docbook
  33. 2
      po/ca/amarok.po
  34. 2
      po/de/amarok.po
  35. 2
      po/eo/amarok.po
  36. 2
      po/fa/amarok.po
  37. 2
      po/it/amarok.po
  38. 2
      po/nds/amarok.po
  39. 2
      po/nl/amarok.po
  40. 2
      po/pl/amarok.po
  41. 2
      po/pt/amarok.po
  42. 2
      po/pt_BR/amarok.po
  43. 2
      po/sr/amarok.po

@ -479,7 +479,7 @@ VERSION 1.4.4
* Don't try to copy to collection from urls without kio slaves.
* Don't quit immediately if amarokrc was removed. (BR 134439)
* The DAAP client would crash Amarok under certain conditions when
kdelibs was compiled with asserts on. (BR 132851)
tdelibs was compiled with asserts on. (BR 132851)
* Configuring the toolbar would disable the stop button. Patch by
Markus Kaufhold <M.Kaufhold@gmx.de>. (BR 132477)
* Changed tags of songs on iPods would not propagate to its database.
@ -1993,7 +1993,7 @@ VERSION 1.2.2:
* Images shown on OSD where incorrect for action notifications.
* The handbook translations were not built when amaroK was installed from
the tarball. I've written a new release script in Ruby, which can
handle the new structure of kde-i18n. (BR 100498)
handle the new structure of tde-i18n. (BR 100498)
* GStreamer-engine can now play vorbis radio streams properly, with
full metadata support. (BR 89821)
* GStreamer-engine now uses the "decodebin" autoplugger, which fixes
@ -2539,7 +2539,7 @@ VERSION 0.9-beta2:
CHG: transformed "EQ" button into a togglebutton, which can also hide the effect browser
ADD: new OpenGL analyzer, contributed by Enrico Ros <eros.kde@email.it>
FIX: FreeBSD compile fixes, contributed by Markus Brueffer <brueffer@phoenix-systems.de>
FIX: rewritten configure: checks properly for kdemultimedia presence,
FIX: rewritten configure: checks properly for tdemultimedia presence,
and adds --without-opengl and --without-gstreamer arguments
VERSION 0.9-beta1:
@ -2615,7 +2615,7 @@ VERSION 0.8.0:
available.
FIX: libamarokarts detection code
ADD: added long-awaited DCOP methods for manipulating the playback. This also adds
integration with kdeaddons/kicker-applets/mediacontrol.
integration with tdeaddons/kicker-applets/mediacontrol.
CHG: moved DCOP handler to a separate class/file
ADD: threaded playlist insertion
FIX: removed bugs and waste code keyhandling in browser*, it mostly works as expected

@ -23,8 +23,8 @@ dnl IMPORTANT NOTE:
dnl Please do not modify this file unless you expect your modifications to be
dnl carried into every other module in the repository.
dnl
dnl Single-module modifications are best placed in configure.in for kdelibs
dnl and kdebase or configure.in.in if present.
dnl Single-module modifications are best placed in configure.in for tdelibs
dnl and tdebase or configure.in.in if present.
# KDE_PATH_X_DIRECT
dnl Internal subroutine of AC_PATH_X.
@ -103,41 +103,41 @@ ac_x_libraries=],
[LIBS="$ac_save_LIBS"
# First see if replacing the include by lib works.
# Check X11 before X11Rn because it is often a symlink to the current release.
for ac_dir in `echo "$ac_x_includes" | sed s/include/lib${kdelibsuff}/` \
/usr/X11/lib${kdelibsuff} \
/usr/X11R6/lib${kdelibsuff} \
/usr/X11R5/lib${kdelibsuff} \
/usr/X11R4/lib${kdelibsuff} \
for ac_dir in `echo "$ac_x_includes" | sed s/include/lib${tdelibsuff}/` \
/usr/X11/lib${tdelibsuff} \
/usr/X11R6/lib${tdelibsuff} \
/usr/X11R5/lib${tdelibsuff} \
/usr/X11R4/lib${tdelibsuff} \
\
/usr/lib${kdelibsuff}/X11 \
/usr/lib${kdelibsuff}/X11R6 \
/usr/lib${kdelibsuff}/X11R5 \
/usr/lib${kdelibsuff}/X11R4 \
/usr/lib${tdelibsuff}/X11 \
/usr/lib${tdelibsuff}/X11R6 \
/usr/lib${tdelibsuff}/X11R5 \
/usr/lib${tdelibsuff}/X11R4 \
\
/usr/local/X11/lib${kdelibsuff} \
/usr/local/X11R6/lib${kdelibsuff} \
/usr/local/X11R5/lib${kdelibsuff} \
/usr/local/X11R4/lib${kdelibsuff} \
/usr/local/X11/lib${tdelibsuff} \
/usr/local/X11R6/lib${tdelibsuff} \
/usr/local/X11R5/lib${tdelibsuff} \
/usr/local/X11R4/lib${tdelibsuff} \
\
/usr/local/lib${kdelibsuff}/X11 \
/usr/local/lib${kdelibsuff}/X11R6 \
/usr/local/lib${kdelibsuff}/X11R5 \
/usr/local/lib${kdelibsuff}/X11R4 \
/usr/local/lib${tdelibsuff}/X11 \
/usr/local/lib${tdelibsuff}/X11R6 \
/usr/local/lib${tdelibsuff}/X11R5 \
/usr/local/lib${tdelibsuff}/X11R4 \
\
/usr/X386/lib${kdelibsuff} \
/usr/x386/lib${kdelibsuff} \
/usr/XFree86/lib${kdelibsuff}/X11 \
/usr/X386/lib${tdelibsuff} \
/usr/x386/lib${tdelibsuff} \
/usr/XFree86/lib${tdelibsuff}/X11 \
\
/usr/lib${kdelibsuff} \
/usr/local/lib${kdelibsuff} \
/usr/unsupported/lib${kdelibsuff} \
/usr/athena/lib${kdelibsuff} \
/usr/local/x11r5/lib${kdelibsuff} \
/usr/lpp/Xamples/lib${kdelibsuff} \
/lib/usr/lib${kdelibsuff}/X11 \
/usr/lib${tdelibsuff} \
/usr/local/lib${tdelibsuff} \
/usr/unsupported/lib${tdelibsuff} \
/usr/athena/lib${tdelibsuff} \
/usr/local/x11r5/lib${tdelibsuff} \
/usr/lpp/Xamples/lib${tdelibsuff} \
/lib/usr/lib${tdelibsuff}/X11 \
\
/usr/openwin/lib${kdelibsuff} \
/usr/openwin/share/lib${kdelibsuff} \
/usr/openwin/lib${tdelibsuff} \
/usr/openwin/share/lib${tdelibsuff} \
; \
do
dnl Don't even attempt the hair of trying to link an X program!
@ -378,7 +378,7 @@ if AC_TRY_EVAL(ac_link) && test -s conftest; then
else
AC_MSG_ERROR([your system fails at linking a small KDE application!
Check, if your compiler is installed correctly and if you have used the
same compiler to compile Qt and kdelibs as you did use now.
same compiler to compile Qt and tdelibs as you did use now.
For more details about this problem, look at the end of config.log.])
fi
@ -937,7 +937,7 @@ mips-sgi-irix6*)
ac_x_includes="."
fi
if test -z "$ac_x_libraries"; then
ac_x_libraries="/usr/lib${kdelibsuff}"
ac_x_libraries="/usr/lib${tdelibsuff}"
fi
esac
#from now on we use our own again
@ -1226,7 +1226,7 @@ if test $kde_qtver = 4; then
kde_qt_dirs="$QTDIR /usr/lib/qt4 /usr/lib/qt /usr/share/qt4"
fi
if test $kde_qtver = 3; then
kde_qt_dirs="$QTDIR /usr/lib/qt3 /usr/lib/qt /usr/share/qt3 /usr/lib${kdelibsuff}/qt-3.3"
kde_qt_dirs="$QTDIR /usr/lib/qt3 /usr/lib/qt /usr/share/qt3 /usr/lib${tdelibsuff}/qt-3.3"
if test -z "$PKG_CONFIG"; then
AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
fi
@ -1426,7 +1426,7 @@ qt_includes=""
AC_ARG_WITH(qt-dir,
AC_HELP_STRING([--with-qt-dir=DIR],[where the root of Qt is installed ]),
[ ac_qt_includes="$withval"/include
ac_qt_libraries="$withval"/lib${kdelibsuff}
ac_qt_libraries="$withval"/lib${tdelibsuff}
ac_qt_bindir="$withval"/bin
])
@ -1475,7 +1475,7 @@ ac_qt_includes="$qt_incdir"
qt_libdirs=""
for dir in $kde_qt_dirs; do
qt_libdirs="$qt_libdirs $dir/lib${kdelibsuff} $dir/lib $dir"
qt_libdirs="$qt_libdirs $dir/lib${tdelibsuff} $dir/lib $dir"
done
if test -z "$PKG_CONFIG"; then
AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
@ -1668,11 +1668,11 @@ rm -f actest.ui actest.cpp
AC_MSG_RESULT([$kde_cv_uic_plugins])
if test "$kde_cv_uic_plugins" != yes; then
AC_MSG_ERROR([
you need to install kdelibs first.
you need to install tdelibs first.
If you did install kdelibs, then the Qt version that is picked up by
this configure is not the same version you used to compile kdelibs.
The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
If you did install tdelibs, then the Qt version that is picked up by
this configure is not the same version you used to compile tdelibs.
The Qt Plugin installed by tdelibs is *ONLY* loadable if it is the
_same Qt version_, compiled with the _same compiler_ and the same Qt
configuration settings.
])
@ -1829,8 +1829,8 @@ in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!])
fi
kde_libdirs="$kde_libs_prefix/lib${kdelibsuff} /usr/lib/kde/lib${kdelibsuff} /usr/local/kde/lib${kdelibsuff} /usr/kde/lib${kdelibsuff} /usr/lib${kdelibsuff}/kde /usr/lib${kdelibsuff}/trinity /usr/lib${kdelibsuff} /usr/X11R6/lib${kdelibsuff} /usr/local/lib${kdelibsuff} /opt/trinity/lib${kdelibsuff} /opt/kde/lib${kdelibsuff} /usr/X11R6/kde/lib${kdelibsuff}"
test -n "$KDEDIR" && kde_libdirs="$KDEDIR/lib${kdelibsuff} $KDEDIR $kde_libdirs"
kde_libdirs="$kde_libs_prefix/lib${tdelibsuff} /usr/lib/kde/lib${tdelibsuff} /usr/local/kde/lib${tdelibsuff} /usr/kde/lib${tdelibsuff} /usr/lib${tdelibsuff}/kde /usr/lib${tdelibsuff}/trinity /usr/lib${tdelibsuff} /usr/X11R6/lib${tdelibsuff} /usr/local/lib${tdelibsuff} /opt/trinity/lib${tdelibsuff} /opt/kde/lib${tdelibsuff} /usr/X11R6/kde/lib${tdelibsuff}"
test -n "$KDEDIR" && kde_libdirs="$KDEDIR/lib${tdelibsuff} $KDEDIR $kde_libdirs"
kde_libdirs="$ac_kde_libraries $libdir $kde_libdirs"
AC_FIND_FILE($kde_check_lib, $kde_libdirs, kde_libdir)
ac_kde_libraries="$kde_libdir"
@ -1848,7 +1848,7 @@ fi
if test -n "$kde_widgetdir" && test ! -r "$kde_widgetdir/trinity/plugins/designer/kdewidgets.la"; then
AC_MSG_ERROR([
I can't find the designer plugins. These are required and should have been installed
by kdelibs])
by tdelibs])
fi
if test -n "$kde_widgetdir"; then
@ -1863,7 +1863,7 @@ else
ac_kde_includes=$ac_kde_includes ac_kde_libraries=$ac_kde_libraries"
fi
else dnl test -z $1, e.g. from kdelibs
else dnl test -z $1, e.g. from tdelibs
ac_cv_have_kde="have_kde=no"
@ -3527,9 +3527,9 @@ AC_DEFUN([KDE_CHECK_LIB64],
AC_ARG_ENABLE(libsuffix,
AC_HELP_STRING([--enable-libsuffix],
[/lib directory suffix (64,32,none,auto[=default])]),
kdelibsuff=$enableval, kdelibsuff="auto")
tdelibsuff=$enableval, tdelibsuff="auto")
if test "$kdelibsuff" = "auto"; then
if test "$tdelibsuff" = "auto"; then
cat > conftest.c << EOF
#include <stdio.h>
@ -3537,26 +3537,26 @@ int main() {
return 0;
}
EOF
kdelibsuff=`$CC conftest.c -o conftest.out; ldd conftest.out |sed -ne '/libc.so/{
tdelibsuff=`$CC conftest.c -o conftest.out; ldd conftest.out |sed -ne '/libc.so/{
s,.*/lib\([[^\/]]*\)/.*,\1,
p
}'`
rm -rf conftest.*
fi
if test "$kdelibsuff" = "no" || test "$kdelibsuff" = "none"; then
kdelibsuff=
if test "$tdelibsuff" = "no" || test "$tdelibsuff" = "none"; then
tdelibsuff=
fi
if test -z "$kdelibsuff"; then
if test -z "$tdelibsuff"; then
AC_MSG_RESULT([not using lib directory suffix])
AC_DEFINE(KDELIBSUFF, [""], Suffix for lib directories)
else
if test "$libdir" = '${exec_prefix}/lib'; then
libdir="$libdir${kdelibsuff}"
libdir="$libdir${tdelibsuff}"
AC_SUBST([libdir], ["$libdir"]) dnl ugly hack for lib64 platforms
fi
AC_DEFINE_UNQUOTED(KDELIBSUFF, ["${kdelibsuff}"], Suffix for lib directories)
AC_MSG_RESULT([using lib directory suffix $kdelibsuff])
AC_DEFINE_UNQUOTED(KDELIBSUFF, ["${tdelibsuff}"], Suffix for lib directories)
AC_MSG_RESULT([using lib directory suffix $tdelibsuff])
fi
])
@ -4581,7 +4581,7 @@ fi
PYTHONINC=-I$python_incdir
python_libdirs="$ac_python_dir/lib$kdelibsuff /usr/lib$kdelibsuff /usr/local /usr/lib$kdelibsuff $kde_extra_libs"
python_libdirs="$ac_python_dir/lib$tdelibsuff /usr/lib$tdelibsuff /usr/local /usr/lib$tdelibsuff $kde_extra_libs"
AC_FIND_FILE(libpython$version.so, $python_libdirs, python_libdir)
if test ! -r $python_libdir/libpython$version.so; then
AC_FIND_FILE(libpython$version.a, $python_libdirs, python_libdir)
@ -4971,7 +4971,7 @@ AC_DEFUN([KDE_CONF_FILES],
AC_SUBST(CONF_FILES)
])dnl
dnl This sets the prefix, for arts and kdelibs
dnl This sets the prefix, for arts and tdelibs
dnl Do NOT use in any other module.
dnl It only looks at --prefix, KDEDIR and falls back to /usr/local/kde
AC_DEFUN([KDE_SET_PREFIX_CORE],
@ -5018,9 +5018,9 @@ AC_DEFUN([KDE_SET_PREFIX],
kde_libs_prefix=`$KDECONFIG --prefix`
if test -z "$kde_libs_prefix" || test ! -x "$kde_libs_prefix"; then
AC_MSG_ERROR([$KDECONFIG --prefix outputed the non existant prefix '$kde_libs_prefix' for kdelibs.
AC_MSG_ERROR([$KDECONFIG --prefix outputed the non existant prefix '$kde_libs_prefix' for tdelibs.
This means it has been moved since you installed it.
This won't work. Please recompile kdelibs for the new prefix.
This won't work. Please recompile tdelibs for the new prefix.
])
fi
kde_libs_htmldir=`$KDECONFIG --install html --expandvars`
@ -5686,7 +5686,7 @@ ssl_includes=""
AC_ARG_WITH(ssl-dir,
AC_HELP_STRING([--with-ssl-dir=DIR],[where the root of OpenSSL is installed]),
[ ac_ssl_includes="$withval"/include
ac_ssl_libraries="$withval"/lib$kdelibsuff
ac_ssl_libraries="$withval"/lib$tdelibsuff
])
want_ssl=yes
@ -5706,7 +5706,7 @@ AC_CACHE_VAL(ac_cv_have_ssl,
AC_FIND_FILE(openssl/ssl.h, $ssl_incdirs, ssl_incdir)
ac_ssl_includes="$ssl_incdir"
ssl_libdirs="/usr/lib$kdelibsuff /usr/local/lib$kdelibsuff /usr/ssl/lib$kdelibsuff /usr/local/ssl/lib$kdelibsuff $libdir $prefix/lib$kdelibsuff $exec_prefix/lib$kdelibsuff $kde_extra_libs"
ssl_libdirs="/usr/lib$tdelibsuff /usr/local/lib$tdelibsuff /usr/ssl/lib$tdelibsuff /usr/local/ssl/lib$tdelibsuff $libdir $prefix/lib$tdelibsuff $exec_prefix/lib$tdelibsuff $kde_extra_libs"
if test ! "$ac_ssl_libraries" = "NO"; then
ssl_libdirs="$ac_ssl_libraries $ssl_libdirs"
fi
@ -5943,9 +5943,9 @@ dnl defines KSTUFF_LIBS, KSTUFF_CFLAGS, see pkg-config man page
dnl also defines KSTUFF_PKG_ERRORS on error
AC_DEFUN([KDE_PKG_CHECK_MODULES], [
PKG_CONFIG_PATH="$prefix/lib${kdelibsuff}/pkgconfig:$PKG_CONFIG_PATH"
PKG_CONFIG_PATH="$prefix/lib${tdelibsuff}/pkgconfig:$PKG_CONFIG_PATH"
if test "$prefix" != "$kde_libs_prefix"; then
PKG_CONFIG_PATH="$kde_libs_prefix/lib${kdelibsuff}/pkgconfig:$PKG_CONFIG_PATH"
PKG_CONFIG_PATH="$kde_libs_prefix/lib${tdelibsuff}/pkgconfig:$PKG_CONFIG_PATH"
fi
export PKG_CONFIG_PATH
PKG_CHECK_MODULES([$1],[$2],[$3],[$4])

@ -1,5 +1,5 @@
<!DOCTYPE kdevelop>
<kdevelop>
<!DOCTYPE tdevelop>
<tdevelop>
<general>
<author>Mark Kretschmann</author>
<email>markey@web.de</email>
@ -236,4 +236,4 @@
<customTagfilePath>/home/ian/workspace/local/amarok/tags</customTagfilePath>
<activeTagsFiles/>
</ctagspart>
</kdevelop>
</tdevelop>

@ -1039,7 +1039,7 @@ AC_LANG_CPLUSPLUS
AC_MSG_CHECKING([if KDE is at least 3.4 for DAAP support])
AC_COMPILE_IFELSE([
#include <kdeversion.h>
#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 4, 0 ) )
#error KDE 3.4
#endif

@ -123,7 +123,7 @@ void Options2::retrievePushButton_clicked()
connect( d, TQT_SIGNAL( finished() ), d, TQT_SLOT( delayedDestruct() ) );
connect( d, TQT_SIGNAL( finished() ), this, TQT_SLOT( updateStyleComboBox() ) );
// Due to kdelibs idiocy, KNS::DownloadDialog is /always/ non-modal. So we have to
// Due to tdelibs idiocy, KNS::DownloadDialog is /always/ non-modal. So we have to
// ensure that closing the settings dialog before the DownloadDialog doesn't crash.
TQTimer::singleShot( 0, d, TQT_SLOT( exec() ) );
}

@ -9,7 +9,7 @@
#include <kurl.h> // recursiveUrlExpand
#include <kprocio.h> //Amarok::ProcIO
#include <kio/netaccess.h>
#include <kdeversion.h>
#include <tdeversion.h>
#include "amarok_export.h"

@ -14,7 +14,7 @@
#include <kapplication.h> //invokeMailer()
#include <kdebug.h> //kdBacktrace()
#include <kdeversion.h>
#include <tdeversion.h>
#include <klocale.h>
#include <ktempfile.h>

@ -14,7 +14,7 @@
***************************************************************************/
#include <kconfig.h>
#include <kdeversion.h>
#include <tdeversion.h>
#include <kdialogbase.h>
#include <kglobal.h>
#include <kiconloader.h>

@ -1,7 +1,7 @@
/* This file is part of the KDE project
Copyright (C) 2004 Mark Kretschmann <markey@web.de>
Copyright (C) 2003 Alexander Dymo <cloudtemple@mksat.net>
Copyright (C) 2003 Roberto Raggi <roberto@kdevelop.org>
Copyright (C) 2003 Roberto Raggi <roberto@tdevelop.org>
Copyright (C) 2001 Christoph Cullmann <cullmann@kde.org>
Copyright (C) 2001 Joseph Wenninger <jowenn@kde.org>
Copyright (C) 2001 Anders Lund <anders.lund@lund.tdcadsl.dk>

@ -1,7 +1,7 @@
/* This file is part of the KDE project
Copyright (C) 2004 Max Howell
Copyright (C) 2004 Mark Kretschmann <markey@web.de>
Copyright (C) 2003 Roberto Raggi <roberto@kdevelop.org>
Copyright (C) 2003 Roberto Raggi <roberto@tdevelop.org>
Copyright (C) 2001 Christoph Cullmann <cullmann@kde.org>
Copyright (C) 2001 Joseph Wenninger <jowenn@kde.org>
Copyright (C) 2001 Anders Lund <anders.lund@lund.tdcadsl.dk>

@ -21,7 +21,7 @@
#include "magnatunedatabasehandler.h"
#include "magnatunelistview.h"
#include <kdeversion.h>
#include <tdeversion.h>
#include <klocale.h>
#include <tqcolor.h>

@ -18,7 +18,7 @@
#include "mediabrowser.h"
#include "threadmanager.h"
#include <kdeversion.h>
#include <tdeversion.h>
#include <kdialogbase.h>
#include <ktempfile.h>

@ -522,7 +522,7 @@ OSDWidget::paintMe()
// Convert the ARGB pixmap to an ARGB image
// NOTE 1: TQPixmap::convertToImage() always converts an ARGB pixmap into an RGB image
// NOTE 2: This should eventually make its way into kdelibs or Qt itself,
// NOTE 2: This should eventually make its way into tdelibs or Qt itself,
// as it would also be useful in applications other than Amarok
int w = blendedImage.width();
int h = blendedImage.height();

@ -38,7 +38,7 @@
#include <tqregexp.h>
#include <kapplication.h> //Used for Shoutcast random name generation
#include <kdeversion.h> //TDE_VERSION ifndefs. Remove this once we reach a kde 4 dep
#include <tdeversion.h> //TDE_VERSION ifndefs. Remove this once we reach a kde 4 dep
#include <kiconloader.h> //smallIcon
#include <kio/jobclasses.h> //podcast retrieval
#include <kio/job.h> //podcast retrieval

@ -38,7 +38,7 @@
#include <tqpixmap.h>
#include <tqrect.h>
#include <kdeversion.h>
#include <tdeversion.h>
#include <kfilemetainfo.h>
#include <kglobal.h>
#include <kiconeffect.h>

@ -649,7 +649,7 @@ bool PlaylistWindow::eventFilter( TQObject *o, TQEvent *e )
// intercept F2 for inline tag renaming
// NOTE: tab will move to the next tag
// NOTE: if item is still null don't select first item in playlist, user wouldn't want that. It's silly.
// TODO: berkus has solved the "inability to cancel" issue with KListView, but it's not in kdelibs yet..
// TODO: berkus has solved the "inability to cancel" issue with KListView, but it's not in tdelibs yet..
// item may still be null, but this is safe
// NOTE: column 0 cannot be edited currently, hence we pick column 1

@ -15,7 +15,7 @@
begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE bindings for ruby) from kdebindings v3.4 is required for this script.'
error = 'Korundum (KDE bindings for ruby) from tdebindings v3.4 is required for this script.'
system("dcop", "amarok", "playlist", "popupMessage", "DatabaseScripts: #{error}")
exit
end

@ -21,7 +21,7 @@
#include "tagdialog.h" //showContextMenu()
#include <kapplication.h>
#include <kdeversion.h> //TDE_VERSION ifndefs. Remove this once we reach a kde 4 dep
#include <tdeversion.h> //TDE_VERSION ifndefs. Remove this once we reach a kde 4 dep
#include <kiconloader.h>
#include <klocale.h>
#include <kmultipledrag.h> //startDrag()

@ -1101,7 +1101,7 @@ AC_LANG_CPLUSPLUS
AC_MSG_CHECKING([if KDE is at least 3.4 for DAAP support])
AC_COMPILE_IFELSE([
#include <kdeversion.h>
#include <tdeversion.h>
#if ! ( KDE_IS_VERSION( 3, 4, 0 ) )
#error KDE 3.4
#endif

@ -980,7 +980,7 @@
begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE bindings for ruby) from kdebindings v3.4 is required for this script.'
error = 'Korundum (KDE bindings for ruby) from tdebindings v3.4 is required for this script.'
`kdialog --sorry '#{error}'`
exit
end

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE-bindinger for Ruby) fra kdebindings v3.4 kræves af dette script.'
error = 'Korundum (KDE-bindinger for Ruby) fra tdebindings v3.4 kræves af dette script.'
`kdialog --sorry '#{error}'`
exit
end

@ -1492,7 +1492,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE bindings for ruby) from kdebindings v3.4 is required for this script.'
error = 'Korundum (KDE bindings for ruby) from tdebindings v3.4 is required for this script.'
`kdialog --sorry '#{error}'`
exit
end

@ -1478,7 +1478,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Este script necesita Korundum (interfaz de KDE para ruby) que se encuentra en kdebindings v3.4.'
error = 'Este script necesita Korundum (interfaz de KDE para ruby) que se encuentra en tdebindings v3.4.'
`kdialog --sorry '#{error}'`
exit
end

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE bindings for ruby) from kdebindings v3.4 is required for this script.'
error = 'Korundum (KDE bindings for ruby) from tdebindings v3.4 is required for this script.'
`kdialog --sorry '#{error}'`
exit
end

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE bindings for ruby) from kdebindings v3.4 is required for this script.'
error = 'Korundum (KDE bindings for ruby) from tdebindings v3.4 is required for this script.'
`kdialog --sorry '#{error}'`
exit
end

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE bindings for ruby) from kdebindings v3.4 is required for this script.'
error = 'Korundum (KDE bindings for ruby) from tdebindings v3.4 is required for this script.'
`kdialog --sorry '#{error}'`
exit
end

@ -43,11 +43,11 @@
<answer>
<para
>&amarok; heeft alleen kdelibs nodig, de rest van KDE niet. Installeer dus eerst kdelibs (inclusief alle binaire bestanden die meegeleverd worden, omdat &amarok; enkele van deze bestanden nodig heeft om plugins te vinden en voor de scriptplugins). We hebben een document geschreven over <ulink url="http://amarok.kde.org/amarokwiki/index.php/KDElibs_without_aRts"
>hoe u een minimale kdelibs kunt compileren</ulink
>&amarok; heeft alleen tdelibs nodig, de rest van KDE niet. Installeer dus eerst tdelibs (inclusief alle binaire bestanden die meegeleverd worden, omdat &amarok; enkele van deze bestanden nodig heeft om plugins te vinden en voor de scriptplugins). We hebben een document geschreven over <ulink url="http://amarok.kde.org/amarokwiki/index.php/KDElibs_without_aRts"
>hoe u een minimale tdelibs kunt compileren</ulink
>, welke u misschien handig vindt.</para>
<para
>Sommige functies, zoals de on-screen-display, hebben voor een correcte werking een windowmanager nodig die ondersteuning biedt voor de relevante freedesktop.org-standaarden. GNOME voldoet aan deze standaarden en werkt dus correct, maar fluxbox zal problemen veroorzaken. We zijn toegewijd om &amarok; op elk platform te ondersteunen. We maken gebruik van kdelibs en Qt omdat deze een excellente programmeeromgeving bieden.</para>
>Sommige functies, zoals de on-screen-display, hebben voor een correcte werking een windowmanager nodig die ondersteuning biedt voor de relevante freedesktop.org-standaarden. GNOME voldoet aan deze standaarden en werkt dus correct, maar fluxbox zal problemen veroorzaken. We zijn toegewijd om &amarok; op elk platform te ondersteunen. We maken gebruik van tdelibs en Qt omdat deze een excellente programmeeromgeving bieden.</para>
</answer>
</qandaentry>
@ -555,7 +555,7 @@ print "Error writing tags of $ARGV[0]\n" unless $mp3->set_v2tag($v2tag,&amp;UTF8
>killall -9 artsd</command
> </para>
<para
>In KDE 3.2.x zijn er problemen met de codecs van kdemultimedia, wat kan leiden tot een verstoord afspelen. Kijk voor meer informatie bij dit <ulink url="http://bugs.kde.org/show_bug.cgi?id=80497"
>In KDE 3.2.x zijn er problemen met de codecs van tdemultimedia, wat kan leiden tot een verstoord afspelen. Kijk voor meer informatie bij dit <ulink url="http://bugs.kde.org/show_bug.cgi?id=80497"
>bugrapport</ulink
>. Ook kan het verhogen van de geluidsbuffer in het alsa-configuratiebestand asoundrc een stuk schelen.</para>
</answer>
@ -570,7 +570,7 @@ print "Error writing tags of $ARGV[0]\n" unless $mp3->set_v2tag($v2tag,&amp;UTF8
<answer>
<para
>Of u gebruikt de aRts-engine niet, maar in plaats daarvan GStreamer of Xine, of u probeert dit op te lossen door de module kdemultimedia volledig te installeren. Deze bevat snellere aRts-codecs (zoals libarts_mpeglig.so, etc.).</para>
>Of u gebruikt de aRts-engine niet, maar in plaats daarvan GStreamer of Xine, of u probeert dit op te lossen door de module tdemultimedia volledig te installeren. Deze bevat snellere aRts-codecs (zoals libarts_mpeglig.so, etc.).</para>
</answer>
</qandaentry>
@ -943,7 +943,7 @@ print "Error writing tags of $ARGV[0]\n" unless $mp3->set_v2tag($v2tag,&amp;UTF8
<qandaentry>
<question>
<para
>Waarom is &amarok; geen onderdeel van kdemultimedia?</para>
>Waarom is &amarok; geen onderdeel van tdemultimedia?</para>
</question>
<answer>

@ -117,7 +117,7 @@
<note
><para
>Voor het afspelen van audio-cd's maakt gebruik van het protocol audiocd:/ (beschikbaar in het softwarepakket kdemultimedia). Dit protocol is niet voor alle beschikbare geluidsengines geschikt.</para
>Voor het afspelen van audio-cd's maakt gebruik van het protocol audiocd:/ (beschikbaar in het softwarepakket tdemultimedia). Dit protocol is niet voor alle beschikbare geluidsengines geschikt.</para
></note>
</sect1>

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (powiązania KDE dla języka Ruby) z pakietu kdebindings v3.4 są wymagane przez ten skrypt.'
error = 'Korundum (powiązania KDE dla języka Ruby) z pakietu tdebindings v3.4 są wymagane przez ten skrypt.'
`kdialog --sorry '#{error}'`
exit
end

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'É necessário o Korundum (interface para o KDE em Ruby) do kdebindings v3.4 neste programa.'
error = 'É necessário o Korundum (interface para o KDE em Ruby) do tdebindings v3.4 neste programa.'
`kdialog --sorry '#{error}'`
exit
end

@ -1480,7 +1480,7 @@
>begin
require 'Korundum'
rescue LoadError
error = 'Korundum (KDE-kopplingar för Ruby) från kdebindings v3.4 krävs för det här skriptet.'
error = 'Korundum (KDE-kopplingar för Ruby) från tdebindings v3.4 krävs för det här skriptet.'
`kdialog --sorry '#{error}'`
exit
end

@ -570,7 +570,7 @@ print "Fel vid skrivning av taggen till $ARGV[0]\n" unless $mp3->set_v2tag($v2ta
<answer>
<para
>Använd antingen inte aRts-gränssnittet, utan använd Gstreamer- eller xine-gränssnitten, eller hantera den höga processoranvändningen genom att installera kdemultimedia i sin helhet för att få de snabbare aRts-avkodarna (t.ex. libarts_mpeglib.so, etc.).</para>
>Använd antingen inte aRts-gränssnittet, utan använd Gstreamer- eller xine-gränssnitten, eller hantera den höga processoranvändningen genom att installera tdemultimedia i sin helhet för att få de snabbare aRts-avkodarna (t.ex. libarts_mpeglib.so, etc.).</para>
</answer>
</qandaentry>

@ -13,7 +13,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-05-12 12:43+0200\n"
"Last-Translator: Josep Ma. Ferrer <txemaq@gmail.com>\n"
"Language-Team: Catalan <kde-i18n-ca@kde.org>\n"
"Language-Team: Catalan <tde-i18n-ca@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -9,7 +9,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-07-06 16:25+0200\n"
"Last-Translator: Thomas Reitelbach <tr@erdfunkstelle.de>\n"
"Language-Team: German <kde-i18n-de@kde.org>\n"
"Language-Team: German <tde-i18n-de@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -7,7 +7,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2007-03-22 00:20+0100\n"
"Last-Translator: Stéphane Fillod <f8cfe@free.fr>\n"
"Language-Team: Esperanto <kde-i18n-eo@kde.org>\n"
"Language-Team: Esperanto <tde-i18n-eo@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -8,7 +8,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2007-02-19 09:46+0330\n"
"Last-Translator: MaryamSadat Razavi <razavi@itland.ir>\n"
"Language-Team: Persian <kde-i18n-fa@kde.org>\n"
"Language-Team: Persian <tde-i18n-fa@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -9,7 +9,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-06-17 00:59+0100\n"
"Last-Translator: Vincenzo Reale <smart2128@baslug.org>\n"
"Language-Team: Italian <kde-i18n-it@mail.kde.org>\n"
"Language-Team: Italian <tde-i18n-it@mail.kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -8,7 +8,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-05-06 23:40+0200\n"
"Last-Translator: Sönke Dibbern <s_dibbern@web.de>\n"
"Language-Team: Low Saxon <kde-i18n-nds@kde.org>\n"
"Language-Team: Low Saxon <tde-i18n-nds@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -15,7 +15,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-04-06 01:39+0200\n"
"Last-Translator: Bram Schoenmakers <bramschoenmakers@kde.nl>\n"
"Language-Team: Nederlands <kde-i18n-nl@kde.org>\n"
"Language-Team: Nederlands <tde-i18n-nl@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -1,6 +1,6 @@
# translation of amarok.po to Polish
# Cezary Morga <cezarym@pf.pl>, 2004, 2005.
# Michal Rudolf <mrudolf@kdewebdev.org>, 2004, 2005.
# Michal Rudolf <mrudolf@tdewebdev.org>, 2004, 2005.
# Krzysztof Lichota <lichota@mimuw.edu.pl>, 2005, 2006, 2007.
# Łukasz Derkacz <nikko@ift.uni.wroc.pl>, 2005.
# Łukasz Derkacz <nibbana@interia.pl>, 2005, 2006.

@ -4,7 +4,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2007-11-25 13:18+0000\n"
"Last-Translator: José Nuno Coelho Pires <jncp@netcabo.pt>\n"
"Language-Team: pt <kde-i18n-pt@kde.org>\n"
"Language-Team: pt <tde-i18n-pt@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -17,7 +17,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-04-05 07:29-0300\n"
"Last-Translator: doutor.zero <doutor.zero@gmail.com>\n"
"Language-Team: Português do Brasil <kde-i18n-pt_br@kde.org>\n"
"Language-Team: Português do Brasil <tde-i18n-pt_br@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

@ -11,7 +11,7 @@ msgstr ""
"POT-Creation-Date: 2008-07-08 01:26+0200\n"
"PO-Revision-Date: 2008-06-19 11:52+0200\n"
"Last-Translator: Slobodan Simic <simicsl@verat.net>\n"
"Language-Team: Serbian <kde-i18n-sr@kde.org>\n"
"Language-Team: Serbian <tde-i18n-sr@kde.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"

Loading…
Cancel
Save