kgtk-qt3 – TDE dialogs in GTK 2.x applications
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

CMakeLists.txt.orig 2.5KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. project(KGtk)
  2. cmake_minimum_required(VERSION 2.4.0)
  3. set(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}/README")
  4. set(CPACK_GENERATOR "TBZ2")
  5. set(CPACK_SOURCE_GENERATOR "TBZ2")
  6. set(CPACK_PACKAGE_VERSION_MAJOR "0")
  7. set(CPACK_PACKAGE_VERSION_MINOR "10")
  8. set(CPACK_PACKAGE_VERSION_PATCH "1")
  9. set(KGTK_VERSION "${CPACK_PACKAGE_VERSION_MAJOR}.${CPACK_PACKAGE_VERSION_MINOR}")
  10. set(KGTK_VERSION_FULL "${KGTK_VERSION}.${CPACK_PACKAGE_VERSION_PATCH}")
  11. set(CPACK_SOURCE_PACKAGE_FILE_NAME "${CMAKE_PROJECT_NAME}-${KGTK_VERSION_FULL}")
  12. include(CPack)
  13. set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
  14. include(CheckFunctionExists)
  15. check_function_exists(getpeereid HAVE_GETPEEREID)
  16. SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -I/usr/include/tqt -include tqt.h -DTQT_THREAD_SUPPORT")
  17. SET(QT_UIC_EXECUTABLE "/usr/bin/uic-tqt")
  18. #SET(QT_MOC_EXECUTABLE "/usr/bin/tmoc")
  19. if (NOT "${KGTK_KDE3}" MATCHES "false")
  20. add_subdirectory(kdialogd3)
  21. endif (NOT "${KGTK_KDE3}" MATCHES "false")
  22. if (NOT "${KGTK_GTK2}" MATCHES "false")
  23. # Check if we have dlvsym...
  24. find_library(LIBDLVSYM_LIBRARY
  25. NAMES dl
  26. PATHS /lib /usr/lib /usr/X11R6/lib /usr/local/lib)
  27. if(LIBDLVSYM_LIBRARY)
  28. set(HAVE_DLVSYM 1)
  29. # Determine version of dlsym...
  30. find_library(LIBDL_LIBRARY
  31. NAMES dl
  32. PATHS /lib /usr/lib /usr/X11R6/lib /usr/local/lib)
  33. if(LIBDL_LIBRARY)
  34. execute_process(COMMAND objdump --dynamic-syms ${LIBDL_LIBRARY}
  35. COMMAND grep dlsym
  36. OUTPUT_VARIABLE DLSYM_DATA)
  37. separate_arguments(DLSYM_DATA)
  38. if (${CMAKE_MAJOR_VERSION} GREATER 2 OR ${CMAKE_MINOR_VERSION} GREATER 4)
  39. cmake_policy(SET CMP0007 OLD)
  40. endif (${CMAKE_MAJOR_VERSION} GREATER 2 OR ${CMAKE_MINOR_VERSION} GREATER 4)
  41. list(GET DLSYM_DATA 4 KGTK_DLSYM_VERSION)
  42. endif(LIBDL_LIBRARY)
  43. else(LIBDLVSYM_LIBRARY)
  44. message("** INFORMATION: You're libdl does not contain dlvsym - SWT apps will not be supported")
  45. endif(LIBDLVSYM_LIBRARY)
  46. add_subdirectory(gtk2)
  47. endif (NOT "${KGTK_GTK2}" MATCHES "false")
  48. if (NOT "${KGTK_QT3}" MATCHES "false")
  49. add_subdirectory(qt3)
  50. endif (NOT "${KGTK_QT3}" MATCHES "false")
  51. install(PROGRAMS ${CMAKE_SOURCE_DIR}/kdialogd-wrapper DESTINATION bin)
  52. install(PROGRAMS ${CMAKE_SOURCE_DIR}/kgtk-wrapper DESTINATION bin)
  53. message("** INFORMATION: Using installation prefix: ${CMAKE_INSTALL_PREFIX}")
  54. configure_file (config.h.cmake ${CMAKE_BINARY_DIR}/config.h)