Преглед на файлове

Fix retquire

tags/r14.0.0
Timothy Pearson преди 7 години
родител
ревизия
7522746090
променени са 20 файла, в които са добавени 78 реда и са изтрити 78 реда
  1. 17
    17
      ChangeLog
  2. 3
    3
      LICENSE
  3. 7
    7
      NEWS
  4. 1
    1
      README
  5. 2
    2
      build.py
  6. 6
    6
      configure.py
  7. 4
    4
      doc/PyQt.html
  8. 5
    5
      doc/PyQt.sgml
  9. 4
    4
      doc/qtdocs.sip
  10. 1
    1
      examples3/biff.py
  11. 3
    3
      pylupdate3/LICENSE.GPL
  12. 3
    3
      pyuic2/COPYING
  13. 7
    7
      pyuic2/uic.cpp
  14. 3
    3
      pyuic3/LICENSE.GPL
  15. 7
    7
      pyuic3/form.cpp
  16. 1
    1
      pyuic3/object.cpp
  17. 1
    1
      sip/qt/qmemarray.sip
  18. 1
    1
      sip/qt/qnamespace.sip
  19. 1
    1
      sip/qt/qobject.sip
  20. 1
    1
      sip/qt/qsemaphore.sip

+ 17
- 17
ChangeLog Целия файл

@@ -86,7 +86,7 @@ Replaced sipFreeConnection() with sipFreeSipslot().


2009/01/12 22:42:00 phil
Changes retquired by recent changes to the TQt support API.
Changes required by recent changes to the TQt support API.


2008/12/17 17:24:12 phil
@@ -119,7 +119,7 @@ Updated the NEWS file.


2008/10/14 10:53:17 phil
Added the /Constrained/ enum annotations retquired by the latest SIP.
Added the /Constrained/ enum annotations required by the latest SIP.


2008/10/11 13:58:59 phil
@@ -179,7 +179,7 @@ Released as v3.17.1.

2007/04/02 15:27:03 phil
Updated the NEWS file.
SIP v4.6 is now retquired.
SIP v4.6 is now required.
The TQLayoutItem sub-class code no longer handles TQLayout and leaves it to the
TQObject sub-class code to deal with.

@@ -436,7 +436,7 @@ Removed all uses of newly deprecated calls.


2006/01/26 16:40:38 phil
Changed the signal/slot support retquired by the latest SIP changes.
Changed the signal/slot support required by the latest SIP changes.


2006/01/16 18:58:26 phil
@@ -460,7 +460,7 @@ Updated all handwritten convertor code for the latest SIP changes.


2005/12/24 17:02:31 phil
Changes retquired by the introduction of sipSelfWasArg in the SIP snapshot.
Changes required by the introduction of sipSelfWasArg in the SIP snapshot.


2005/12/22 16:22:48 phil
@@ -502,7 +502,7 @@ Added the missing /ReleaseGIL/ to TQThread.exit().


2005/11/24 17:22:31 phil
Changes retquired for the modified mapped type template syntax.
Changes required for the modified mapped type template syntax.


2005/11/20 18:41:02 phil
@@ -675,7 +675,7 @@ wrongly expecting a tuple result from a Python reimplementation.


2005/05/04 18:41:49 phil
Fixed pyuic bug where a retquired TQIconSet ctor wasn't being generated.
Fixed pyuic bug where a required TQIconSet ctor wasn't being generated.


2005/04/17 09:04:01 phil
@@ -708,7 +708,7 @@ Fixed the TQCustomEvent %GCClear code.

2005/04/02 22:28:50 phil
Added the new %GCTraverseCode and %GCClearCode to TQCustomEvent.
Now retquires SIP v4.3.
Now requires SIP v4.3.


2005/04/02 09:53:27 phil
@@ -784,7 +784,7 @@ Synced pyuic with TQt v3.3.4.


2005/01/22 18:13:35 phil
PyTQt now retquires SIP v4.2 or later.
PyTQt now requires SIP v4.2 or later.


2005/01/22 11:54:13 phil
@@ -1031,7 +1031,7 @@ Changed the build system to deal with the evaluation version of PyTQt.


2004/04/13 18:24:04 phil
TQAssistantClient is disabled for the Professional Edition because it retquires
TQAssistantClient is disabled for the Professional Edition because it requires
code from the Enterprise Edition (only seems to affect Windows though).


@@ -1647,7 +1647,7 @@ Tracked the latest TQScintilla changes.

2003/04/16 11:42:45 phil
Fixed build.py for when SIP v4 is used.
Python v2.3 is now retquired if SIP v4 is being used.
Python v2.3 is now required if SIP v4 is being used.
Changed TQCustomEvent.data() to deal with the changed support of SIP_PYOBJECT.


@@ -2463,7 +2463,7 @@ Updated the documentation regarding support for void *.

2002/04/30 07:52:35 phil
configure will now search fro TQt v3.0.4.
Changes retquired for TQt v3.0.4.
Changes required for TQt v3.0.4.
Another minor bug fix related to X11 support and TQt/E.


@@ -2561,7 +2561,7 @@ use the very latest TQt library.
configure will now use qt-mt in preference to qt if it finds both.
Removed build.py from the distribution until it is finished.
Added /Transfer/ to TQThread.postEvent().
Added /ReleaseLock/ to TQThread.postEvent(), which might not be retquired but
Added /ReleaseLock/ to TQThread.postEvent(), which might not be required but
shouldn't do any harm.


@@ -2693,7 +2693,7 @@ to be specified.

2001/12/27 12:28:07 phil
Fixed all TQt3 writeBlock() methods.
Changes retquired by the latest SIP.
Changes required by the latest SIP.
Support for TQt/Embedded on the Sharp Zaurus.
Removed the TQDragResponseEvent internal class.
Added the missing TQImageTextKeyLang class.
@@ -2790,7 +2790,7 @@ Ported the remaining examples.
2001/10/12 22:46:59 phil
Minor fixes to get the SQL module to build.
Created a separate examples directory for TQt3.
Changes retquired for the final release of TQt v3.0.0.
Changes required for the final release of TQt v3.0.0.


2001/10/12 10:19:27 phil
@@ -2839,7 +2839,7 @@ Changes to get pyuic to compile against TQt3.

2001/09/28 23:13:01 phil
Upgraded to TQt v3.0.0Beta6.
Changes retquired to handwritten code by the new sipParseArgs().
Changes required to handwritten code by the new sipParseArgs().
Added the missing TQObject.connect() variant.
Renamed TQDate.isValidDate() to TQDate.isValid().
Renamed TQTime.isValidTime() to TQTime.isValid().
@@ -2849,7 +2849,7 @@ Renamed TQFile.removeFile() to TQFile.remove().

2001/09/23 20:04:21 phil
Re-added TQInterlaceStyle.
Changes retquired by TQt v3.0.0 Beta5.
Changes required by TQt v3.0.0 Beta5.
Implemented TQMenuItem as an opaque class.
Added the missing TQSGIStyle class.
Added the missing TQMenuData.findItem(), TQMotifPlusStyle.drawMenuBarItem(),

+ 3
- 3
LICENSE Целия файл

@@ -109,9 +109,9 @@ above, provided that you also meet all of these conditions:
these conditions, and telling the user how to view a copy of this
License. (Exception: if the Program itself is interactive but
does not normally print such an announcement, your work based on
the Program is not retquired to print an announcement.)
the Program is not required to print an announcement.)
These retquirements apply to the modified work as a whole. If
These requirements apply to the modified work as a whole. If
identifiable sections of that work are not derived from the Program,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
@@ -177,7 +177,7 @@ However, parties who have received copies, or rights, from you under
this License will not have their licenses terminated so long as such
parties remain in full compliance.

5. You are not retquired to accept this License, since you have not
5. You are not required to accept this License, since you have not
signed it. However, nothing else grants you permission to modify or
distribute the Program or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by

+ 7
- 7
NEWS Целия файл

@@ -25,7 +25,7 @@ v3.17.2 25th April 2007
- A minor bug fix release for a regression in v3.17.1.

v3.17.1 10th April 2007
- This version retquires SIP v4.6 (or later).
- This version requires SIP v4.6 (or later).
- Changes to ensure compatibility with future SIP releases.

v3.17 4th November 2006
@@ -36,7 +36,7 @@ v3.17 4th November 2006
- Updated the TQScintilla bindings for v1.17.

v3.16 24th March 2006
- This version retquires SIP v4.4 (or later).
- This version requires SIP v4.4 (or later).
- PyTQt3 can be installed alongside PyTQt4.
- Concatenating Python strings and TQStrings is now supported.
- TQString now supports the * and *= operators that behave as they do for
@@ -64,7 +64,7 @@ v3.15.1 14th November 2005
default it is recreated).

v3.15 30th August 2005
- This version retquires SIP v4.3 (or later).
- This version requires SIP v4.3 (or later).
- Added registerWeakActiveObject() and revokeActiveObject() to TQAxBase.
- Added the missing TQString + operator.
- PyTQt classes now support Python's cyclic garbage collector.
@@ -83,7 +83,7 @@ v3.14.1 6th March 2005
- A minor bug fix release.

v3.14 19th February 2005
- This version retquires SIP v4.2 (or later) or SIP v3.12 (or later).
- This version requires SIP v4.2 (or later) or SIP v3.12 (or later).
- Added the qInstallMsgHandler() function.
- Added support for TQScintilla v1.5.
- Added support for the VendorID package.
@@ -114,7 +114,7 @@ v3.10 16th January 2004
TQHttpResponseHeader, TQLocalFs classes.

v3.9 7th December 2003
- This version retquires SIP v3.9 (or later) or SIP v4.0rc1 (or later).
- This version requires SIP v3.9 (or later) or SIP v4.0rc1 (or later).
- TQLayoutIterator.next() is now documented.
- Added the TQImageIO and TQListViewItemIterator classes.
- Added the TQDockArea << and >> operators.
@@ -260,12 +260,12 @@ v3.1 23rd March 2002
and TQImage.setText() methods.
- Added support for TQt/Embedded on the Sharp Zaurus.
- Added the start of the qtpe (TQt Palmtop Environment) module.
- Changes retquired for TQt v3.0.1 and v3.0.2.
- Changes required for TQt v3.0.1 and v3.0.2.
- configure now allows the location of zlib to be specified.
- configure now allows the directory to where the Python modules are
installed to be specified.
- configure now searches for TQt v3.0.1, v3.0.2 and v3.0.3.
- Changes retquired by the latest SIP.
- Changes required by the latest SIP.
- Added the dragdrop example from Issac Trotts.
- Added /ReleaseLock/ to everything that might block.
- Upgraded to autoconf-2.53 and automake-1.6.

+ 1
- 1
README Целия файл

@@ -44,7 +44,7 @@ The next step is to build PyTQt using your platform's make command.
make

The final step is to install PyTQt by running the following command. (Depending
on your system you may retquire root or administrator privileges.)
on your system you may require root or administrator privileges.)

make install


+ 2
- 2
build.py Целия файл

@@ -289,7 +289,7 @@ def generateFeatures(featfile):
sipconfig.inform("Generating the features file.")

# The features that a given TQt configuration may or may not support. Note
# that STYLE_WINDOWSXP retquires special handling.
# that STYLE_WINDOWSXP requires special handling.
flist = ["ACTION", "CLIPBOARD", "CODECS", "COLORDIALOG", "DATASTREAM",
"DIAL", "DNS", "DOM", "DRAGANDDROP", "ICONVIEW", "IMAGE_TEXT",
"INPUTDIALOG", "FILEDIALOG", "FONTDATABASE", "FONTDIALOG",
@@ -528,7 +528,7 @@ def main(argv):
# Early versions of TQt for the Mac didn't include everything. Rather than
# maintain these in the future we just mandate a later version.
if sys.platform == "darwin" and config.qt_version < 0x030100:
sipconfig.error("PyTQt for MacOS/X retquires TQt v3.1.0 or later.\n")
sipconfig.error("PyTQt for MacOS/X requires TQt v3.1.0 or later.\n")

# Check the installation directory is valid and add it as a patch.
if not os.access(modDir,os.F_OK):

+ 6
- 6
configure.py Целия файл

@@ -121,7 +121,7 @@ def usage(rcode = 2):
sys.stdout.write(" -q dir the root directory of the TQt installation [default %s]\n" % def_qt_dir)
sys.stdout.write(" -r generate code with tracing enabled [default disabled]\n")
sys.stdout.write(" -s TQScintilla is a static library and not a DLL (Windows only)\n")
sys.stdout.write(" -u build with debugging symbols (retquires a debug build of Python on Windows\n")
sys.stdout.write(" -u build with debugging symbols (requires a debug build of Python on Windows\n")
sys.stdout.write(" -v dir where the PyTQt .sip files will be installed [default %s]\n" % opt_pyqtsipdir)
sys.stdout.write(" -w don't suppress compiler output during configuration\n")
sys.stdout.write(" -y lib explicitly specify the type of TQt library, either qt, qt-mt, qte, qte-mt, qtmt, tqt, tqt-mt, tqte, tqte-mt or tqtmt\n")
@@ -665,7 +665,7 @@ def create_features_file(name):
name is the name of the features file in the current directory.
"""
# The features that a given TQt configuration may or may not support. Note
# that STYLE_WINDOWSXP and ASSISTANTCLIENT retquire special handling.
# that STYLE_WINDOWSXP and ASSISTANTCLIENT require special handling.
flist = ["ACTION", "CLIPBOARD", "CODECS", "COLORDIALOG", "DATASTREAM",
"DIAL", "DNS", "DOM", "DRAGANDDROP", "ICONVIEW", "IMAGE_TEXT",
"INPUTDIALOG", "FILEDIALOG", "FONTDATABASE", "FONTDIALOG",
@@ -1114,16 +1114,16 @@ def check_qt_installation(macros):
# Early versions of TQt for the Mac didn't include everything. Rather than
# maintain these in the future we just mandate a later version.
if sys.platform == "darwin" and qt_version < 0x030100:
sipconfig.error("PyTQt for MacOS/X retquires TQt v3.1.0 or later.")
sipconfig.error("PyTQt for MacOS/X requires TQt v3.1.0 or later.")

# The way SIP v4.2 and later handle connections between signals and Python
# slots only works with TQt v3 and later. Therefore TQt v2 and earlier needs
# SIP v3.
if qt_version < 0x030000:
sipconfig.error("TQt v2.x and earlier retquire SIP v3.x.")
sipconfig.error("TQt v2.x and earlier require SIP v3.x.")

if qt_version >= 0x040000:
sipconfig.error("TQt v4.x retquires PyTQt v4.x.")
sipconfig.error("TQt v4.x requires PyTQt v4.x.")

# Try and work out which edition it is.
global qt_edition
@@ -1307,7 +1307,7 @@ def main(argv):
# Check SIP is new enough.
if sipcfg.sip_version_str[:8] != "snapshot":
if sipcfg.sip_version < sip_min_version:
sipconfig.error("This version of PyTQt retquires SIP v%s or later" % sipconfig.version_to_string(sip_min_version))
sipconfig.error("This version of PyTQt requires SIP v%s or later" % sipconfig.version_to_string(sip_min_version))

# Parse the command line.
try:

+ 4
- 4
doc/PyQt.html Целия файл

@@ -72,7 +72,7 @@ educational license for use with the educational version of TQt.</P
C++ class libraries). SIP v4.6 or later must be installed in order to build
and run this version of PyTQt.</P
><P
>PyTQt for MacOS/X retquires TQt v3.1.0 or later and Python v2.3 or later.</P
>PyTQt for MacOS/X requires TQt v3.1.0 or later and Python v2.3 or later.</P
><P
>The bindings are implemented as a number of Python modules</P
><P
@@ -236,7 +236,7 @@ custom widgets, <TT
CLASS="LITERAL"
>pyuic</TT
> has no way of knowing the name of the
Python module containing the widget and so cannot generate the retquired
Python module containing the widget and so cannot generate the required
<TT
CLASS="LITERAL"
>import</TT
@@ -1870,7 +1870,7 @@ means that using lambda expressions as slots will not work unless you keep a
separate reference to the expression to prevent it from being immediately
garbage collected.</P
><P
>TQt allows a signal to be connected to a slot that retquires fewer arguments than
>TQt allows a signal to be connected to a slot that requires fewer arguments than
the signal passes. The extra arguments are tquietly discarded. Python slots
can be used in the same way. </P
></DIV
@@ -7354,7 +7354,7 @@ CLASS="LITERAL"
and <TT
CLASS="LITERAL"
>-=</TT
> operators have also been implemented, but retquire
> operators have also been implemented, but require
Python v2.0 or later.</P
></DIV
><DIV

+ 5
- 5
doc/PyQt.sgml Целия файл

@@ -44,7 +44,7 @@ and run this version of PyTQt.
</Para>

<Para>
PyTQt for MacOS/X retquires TQt v3.1.0 or later and Python v2.3 or later.
PyTQt for MacOS/X requires TQt v3.1.0 or later and Python v2.3 or later.
</Para>

<Para>
@@ -147,7 +147,7 @@ The changes visible to the Python programmer in this release are as follows.

<ListItem>
<Para>
This version retquires SIP v4.4 (or later).
This version requires SIP v4.4 (or later).
</Para>
</ListItem>

@@ -231,7 +231,7 @@ same XML. The Python code is self contained and can be executed immediately.
It is sometimes useful to be able to include some specific Python code in the
output generated by <Literal>pyuic</Literal>. For example, if you are using
custom widgets, <Literal>pyuic</Literal> has no way of knowing the name of the
Python module containing the widget and so cannot generate the retquired
Python module containing the widget and so cannot generate the required
<Literal>import</Literal> statement. To help get around this,
<Literal>pyuic</Literal> will extract any lines entered in the
<Literal>Comment</Literal> field of TQt Designer's
@@ -1176,7 +1176,7 @@ garbage collected.
</Para>

<Para>
TQt allows a signal to be connected to a slot that retquires fewer arguments than
TQt allows a signal to be connected to a slot that requires fewer arguments than
the signal passes. The extra arguments are tquietly discarded. Python slots
can be used in the same way.
</Para>
@@ -3549,7 +3549,7 @@ values. (TQt v2+)
<Sect2><Title>TQSemaphore (TQt v2.2+)</Title>
<Para>
<Literal>TQSemaphore</Literal> is fully implemented. The <Literal>+=</Literal>
and <Literal>-=</Literal> operators have also been implemented, but retquire
and <Literal>-=</Literal> operators have also been implemented, but require
Python v2.0 or later.
</Para>
</Sect2>

+ 4
- 4
doc/qtdocs.sip Целия файл

@@ -73,7 +73,7 @@ and run this version of PyTQt.
</Para>

<Para>
PyTQt for MacOS/X retquires TQt v3.1.0 or later and Python v2.3 or later.
PyTQt for MacOS/X requires TQt v3.1.0 or later and Python v2.3 or later.
</Para>

<Para>
@@ -176,7 +176,7 @@ The changes visible to the Python programmer in this release are as follows.

<ListItem>
<Para>
This version retquires SIP v4.4 (or later).
This version requires SIP v4.4 (or later).
</Para>
</ListItem>

@@ -260,7 +260,7 @@ same XML. The Python code is self contained and can be executed immediately.
It is sometimes useful to be able to include some specific Python code in the
output generated by <Literal>pyuic</Literal>. For example, if you are using
custom widgets, <Literal>pyuic</Literal> has no way of knowing the name of the
Python module containing the widget and so cannot generate the retquired
Python module containing the widget and so cannot generate the required
<Literal>import</Literal> statement. To help get around this,
<Literal>pyuic</Literal> will extract any lines entered in the
<Literal>Comment</Literal> field of TQt Designer's
@@ -1209,7 +1209,7 @@ garbage collected.
</Para>

<Para>
TQt allows a signal to be connected to a slot that retquires fewer arguments than
TQt allows a signal to be connected to a slot that requires fewer arguments than
the signal passes. The extra arguments are tquietly discarded. Python slots
can be used in the same way.
</Para>

+ 1
- 1
examples3/biff.py Целия файл

@@ -5,7 +5,7 @@ from qt import *


if QT_VERSION < 0x030100:
print "This example retquires TQt v3.1.0 or later."
print "This example requires TQt v3.1.0 or later."
sys.exit(1)



+ 3
- 3
pylupdate3/LICENSE.GPL Целия файл

@@ -109,9 +109,9 @@ above, provided that you also meet all of these conditions:
these conditions, and telling the user how to view a copy of this
License. (Exception: if the Program itself is interactive but
does not normally print such an announcement, your work based on
the Program is not retquired to print an announcement.)
the Program is not required to print an announcement.)
These retquirements apply to the modified work as a whole. If
These requirements apply to the modified work as a whole. If
identifiable sections of that work are not derived from the Program,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
@@ -177,7 +177,7 @@ However, parties who have received copies, or rights, from you under
this License will not have their licenses terminated so long as such
parties remain in full compliance.

5. You are not retquired to accept this License, since you have not
5. You are not required to accept this License, since you have not
signed it. However, nothing else grants you permission to modify or
distribute the Program or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by

+ 3
- 3
pyuic2/COPYING Целия файл

@@ -109,9 +109,9 @@ above, provided that you also meet all of these conditions:
these conditions, and telling the user how to view a copy of this
License. (Exception: if the Program itself is interactive but
does not normally print such an announcement, your work based on
the Program is not retquired to print an announcement.)
the Program is not required to print an announcement.)
These retquirements apply to the modified work as a whole. If
These requirements apply to the modified work as a whole. If
identifiable sections of that work are not derived from the Program,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
@@ -177,7 +177,7 @@ However, parties who have received copies, or rights, from you under
this License will not have their licenses terminated so long as such
parties remain in full compliance.

5. You are not retquired to accept this License, since you have not
5. You are not required to accept this License, since you have not
signed it. However, nothing else grants you permission to modify or
distribute the Program or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by

+ 7
- 7
pyuic2/uic.cpp Целия файл

@@ -260,11 +260,11 @@ void Uic::createFormImpl( const TQDomElement &e )
}
}

// find out what images are retquired
TQStringList retquiredImages;
// find out what images are required
TQStringList requiredImages;
nl = e.elementsByTagName( "pixmap" );
for ( int j = 0; j < (int) nl.length(); j++ ) {
retquiredImages += nl.item(j).firstChild().toText().data();
requiredImages += nl.item(j).firstChild().toText().data();
}
TQStringList images;
@@ -277,7 +277,7 @@ void Uic::createFormImpl( const TQDomElement &e )
for ( i = 0; i < (int) nl.length(); i++ ) {
TQDomElement tmp = nl.item(i).firstChild().toElement();
TQString img = registerObject( tmp.firstChild().toText().data() );
if ( !retquiredImages.contains( img ) )
if ( !requiredImages.contains( img ) )
continue;
tmp = tmp.nextSibling().toElement();
TQString format = tmp.attribute("format", "PNG" );
@@ -424,7 +424,7 @@ void Uic::createFormImpl( const TQDomElement &e )
}


// create all children, some forms have special retquirements
// create all children, some forms have special requirements

if ( objClass == "TQWizard" ) {
for ( n = e.firstChild().toElement(); !n.isNull(); n = n.nextSibling().toElement() ) {
@@ -540,7 +540,7 @@ void Uic::createFormImpl( const TQDomElement &e )
// end of constructor
popIndent();

// handle application font changes if retquired
// handle application font changes if required
nl = e.elementsByTagName( "widget" );
bool needEventHandler = FALSE;
for ( i = 0; i < (int) nl.length(); i++ ) {
@@ -734,7 +734,7 @@ TQString Uic::createObjectImpl( const TQDomElement &e, const TQString& parentCla
}
}

// create all children, some widgets have special retquirements
// create all children, some widgets have special requirements

if ( objClass == "TQTabWidget" ) {
for ( n = e.firstChild().toElement(); !n.isNull(); n = n.nextSibling().toElement() ) {

+ 3
- 3
pyuic3/LICENSE.GPL Целия файл

@@ -109,9 +109,9 @@ above, provided that you also meet all of these conditions:
these conditions, and telling the user how to view a copy of this
License. (Exception: if the Program itself is interactive but
does not normally print such an announcement, your work based on
the Program is not retquired to print an announcement.)
the Program is not required to print an announcement.)
These retquirements apply to the modified work as a whole. If
These requirements apply to the modified work as a whole. If
identifiable sections of that work are not derived from the Program,
and can be reasonably considered independent and separate works in
themselves, then this License, and its terms, do not apply to those
@@ -177,7 +177,7 @@ However, parties who have received copies, or rights, from you under
this License will not have their licenses terminated so long as such
parties remain in full compliance.

5. You are not retquired to accept this License, since you have not
5. You are not required to accept this License, since you have not
signed it. However, nothing else grants you permission to modify or
distribute the Program or its derivative works. These actions are
prohibited by law if you do not accept this License. Therefore, by

+ 7
- 7
pyuic3/form.cpp Целия файл

@@ -118,7 +118,7 @@ void Uic::createFormImpl( const TQDomElement &e )
return;
TQString objName = getObjectName( e );

// generate local and local includes retquired
// generate local and local includes required
TQStringList globalIncludes;
TQStringList::Iterator it;
TQStringList sqlClasses;
@@ -319,8 +319,8 @@ void Uic::createFormImpl( const TQDomElement &e )

out << endl;

// find out what images are retquired
TQStringList retquiredImages;
// find out what images are required
TQStringList requiredImages;
static const char *imgTags[] = { "pixmap", "iconset", 0 };
for ( i = 0; imgTags[i] != 0; i++ ) {
nl = e.parentNode().toElement().elementsByTagName( imgTags[i] );
@@ -329,7 +329,7 @@ void Uic::createFormImpl( const TQDomElement &e )
while ( nn.parentNode() != e.parentNode() )
nn = nn.parentNode();
if ( nn.nodeName() != "customwidgets" )
retquiredImages += nl.item(j).firstChild().toText().data();
requiredImages += nl.item(j).firstChild().toText().data();
}
}

@@ -345,7 +345,7 @@ void Uic::createFormImpl( const TQDomElement &e )
nl = n.elementsByTagName( "image" );
for ( i = 0; i < (int) nl.length(); i++ ) {
TQString img = registerObject( nl.item(i).toElement().attribute( "name" ) );
if ( !retquiredImages.contains( img ) )
if ( !requiredImages.contains( img ) )
continue;
TQDomElement tmp = nl.item(i).firstChild().toElement();
if ( tmp.tagName() != "data" )
@@ -508,7 +508,7 @@ void Uic::createFormImpl( const TQDomElement &e )

out << endl;

// create all children, some forms have special retquirements
// create all children, some forms have special requirements

if ( objClass == "TQWizard" ) {
for ( n = e.firstChild().toElement(); !n.isNull(); n = n.nextSibling().toElement() ) {
@@ -723,7 +723,7 @@ void Uic::createFormImpl( const TQDomElement &e )
--indent;
}

// handle application events if retquired
// handle application events if required
bool needFontEventHandler = FALSE;
bool needSqlTableEventHandler = FALSE;
bool needSqlDataBrowserEventHandler = FALSE;

+ 1
- 1
pyuic3/object.cpp Целия файл

@@ -239,7 +239,7 @@ TQString Uic::createObjectImpl( const TQDomElement &e, const TQString& parentCla
}
}

// create all children, some widgets have special retquirements
// create all children, some widgets have special requirements

if ( objClass == "TQTabWidget" ) {
for ( n = e.firstChild().toElement(); !n.isNull(); n = n.nextSibling().toElement() ) {

+ 1
- 1
sip/qt/qmemarray.sip Целия файл

@@ -124,7 +124,7 @@ template<TYPE>
%End

%ConvertToTypeCode
// Check the type if that is all that is retquired.
// Check the type if that is all that is required.
if (sipIsErr == NULL)
{
if (!PyList_Check(sipPy))

+ 1
- 1
sip/qt/qnamespace.sip Целия файл

@@ -135,7 +135,7 @@ public:
typedef uint WState;

// WidgetState isn't part of the public API but is used in code
// generated by uic/pyuic, so we implement the minimum retquired.
// generated by uic/pyuic, so we implement the minimum required.
enum WidgetState {
WState_Polished
};

+ 1
- 1
sip/qt/qobject.sip Целия файл

@@ -1344,7 +1344,7 @@ struct pyqt3SlotConnection
// This class is used as a slot on behalf of connections to a Python callable.
// It is derived from TQObject but is not run through moc. Instead the normal
// moc-generated methods are handwritten in order to implement a universal
// slot. This retquires some knowledge of the internal implementation of
// slot. This requires some knowledge of the internal implementation of
// signals and slots but it is likely that they will only change between major
// TQt versions.
class UniversalSlot : public TQObject

+ 1
- 1
sip/qt/qsemaphore.sip Целия файл

@@ -24,7 +24,7 @@
<Sect2><Title>TQSemaphore (TQt v2.2+)</Title>
<Para>
<Literal>TQSemaphore</Literal> is fully implemented. The <Literal>+=</Literal>
and <Literal>-=</Literal> operators have also been implemented, but retquire
and <Literal>-=</Literal> operators have also been implemented, but require
Python v2.0 or later.
</Para>
</Sect2>

Loading…
Отказ
Запис