Shared admin folder
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

pkg.m4.in 2.0KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. dnl PKG_CHECK_MODULES(GSTUFF, gtk+-2.0 >= 1.3 glib = 1.3.4, action-if, action-not)
  2. dnl defines GSTUFF_LIBS, GSTUFF_CFLAGS, see pkg-config man page
  3. dnl also defines GSTUFF_PKG_ERRORS on error
  4. AC_DEFUN([PKG_CHECK_MODULES], [
  5. succeeded=no
  6. if test -z "$PKG_CONFIG"; then
  7. AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
  8. fi
  9. if test "$PKG_CONFIG" = "no" ; then
  10. echo "*** The pkg-config script could not be found. Make sure it is"
  11. echo "*** in your path, or set the PKG_CONFIG environment variable"
  12. echo "*** to the full path to pkg-config."
  13. echo "*** Or see http://www.freedesktop.org/software/pkgconfig to get pkg-config."
  14. else
  15. PKG_CONFIG_MIN_VERSION=0.9.0
  16. if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
  17. AC_MSG_CHECKING(for $2)
  18. if $PKG_CONFIG --exists "$2" ; then
  19. AC_MSG_RESULT(yes)
  20. succeeded=yes
  21. AC_MSG_CHECKING($1_CFLAGS)
  22. $1_CFLAGS=`$PKG_CONFIG --cflags "$2"`
  23. AC_MSG_RESULT($$1_CFLAGS)
  24. AC_MSG_CHECKING($1_LIBS)
  25. $1_LIBS=`$PKG_CONFIG --libs "$2"`
  26. AC_MSG_RESULT($$1_LIBS)
  27. else
  28. $1_CFLAGS=""
  29. $1_LIBS=""
  30. ## If we have a custom action on failure, don't print errors, but
  31. ## do set a variable so people can do so.
  32. $1_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "$2"`
  33. ifelse([$4], ,echo $$1_PKG_ERRORS,)
  34. fi
  35. AC_SUBST($1_CFLAGS)
  36. AC_SUBST($1_LIBS)
  37. else
  38. echo "*** Your version of pkg-config is too old. You need version $PKG_CONFIG_MIN_VERSION or newer."
  39. echo "*** See http://www.freedesktop.org/software/pkgconfig"
  40. fi
  41. fi
  42. if test $succeeded = yes; then
  43. ifelse([$3], , :, [$3])
  44. else
  45. ifelse([$4], , AC_MSG_ERROR([Library requirements ($2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.]), [$4])
  46. fi
  47. ])