Browse Source

RPM: fix dependencies on newly cmake built packages

pull/14/head
François Andriot 6 months ago
parent
commit
666511ebfb
34 changed files with 348 additions and 7 deletions
  1. 9
    0
      redhat/applications/dolphin/dolphin.spec
  2. 9
    0
      redhat/applications/katapult/katapult.spec
  3. 12
    3
      redhat/applications/kbarcode/kbarcode.spec
  4. 15
    4
      redhat/applications/kbibtex/kbibtex.spec
  5. 9
    0
      redhat/applications/kbiff/kbiff.spec
  6. 9
    0
      redhat/applications/kbookreader/kbookreader.spec
  7. 9
    0
      redhat/applications/kcmautostart/kcmautostart.spec
  8. 6
    0
      redhat/applications/kcpuload/kcpuload.spec
  9. 9
    0
      redhat/applications/kdirstat/kdirstat.spec
  10. 9
    0
      redhat/applications/kiosktool/kiosktool.spec
  11. 12
    0
      redhat/applications/kkbswitch/kkbswitch.spec
  12. 6
    0
      redhat/applications/klcddimmer/klcddimmer.spec
  13. 9
    0
      redhat/applications/knetload/knetload.spec
  14. 9
    0
      redhat/applications/knetstats/knetstats.spec
  15. 9
    0
      redhat/applications/knights/knights.spec
  16. 9
    0
      redhat/applications/knmap/knmap.spec
  17. 9
    0
      redhat/applications/knutclient/knutclient.spec
  18. 51
    0
      redhat/applications/konversation/konversation.spec
  19. 12
    0
      redhat/applications/kpilot/kpilot.spec
  20. 6
    0
      redhat/applications/ksensors/ksensors.spec
  21. 9
    0
      redhat/applications/kshutdown/kshutdown.spec
  22. 6
    0
      redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec
  23. 9
    0
      redhat/applications/kvkbd/kvkbd.spec
  24. 9
    0
      redhat/applications/kvpnc/kvpnc.spec
  25. 6
    0
      redhat/applications/mplayerthumbs/mplayerthumbs.spec
  26. 9
    0
      redhat/applications/potracegui/potracegui.spec
  27. 9
    0
      redhat/applications/tdeio-ftps/tdeio-ftps.spec
  28. 9
    0
      redhat/applications/tdeio-sword/tdeio-sword.spec
  29. 9
    0
      redhat/applications/tdeio-umountwrapper/tdeio-umountwrapper.spec
  30. 9
    0
      redhat/applications/tdesudo/tdesudo.spec
  31. 9
    0
      redhat/applications/tdmtheme/tdmtheme.spec
  32. 9
    0
      redhat/applications/yakuake/yakuake.spec
  33. 9
    0
      redhat/extras/trinity-filesystem/trinity-filesystem-14.0.0.spec
  34. 9
    0
      redhat/main/tdeadmin/tdeadmin.spec

+ 9
- 0
redhat/applications/dolphin/dolphin.spec View File

@@ -67,6 +67,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/katapult/katapult.spec View File

@@ -65,6 +65,15 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 12
- 3
redhat/applications/kbarcode/kbarcode.spec View File

@@ -68,6 +68,18 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# PCRE support
BuildRequires: pcre-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files
@@ -78,9 +90,6 @@ BuildRequires: update-desktop-files
BuildRequires: brp-check-trinity
%endif

# PCRE support
BuildRequires: pcre-devel

Requires: %{name}-tdefile-plugin = %{?epoch:%{epoch}:}%{version}-%{release}



+ 15
- 4
redhat/applications/kbibtex/kbibtex.spec View File

@@ -67,6 +67,21 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# XSLT support
BuildRequires: libxslt-devel

# YAZ support
BuildRequires: libyaz-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files
@@ -77,10 +92,6 @@ BuildRequires: update-desktop-files
BuildRequires: brp-check-trinity
%endif

# XSLT support
BuildRequires: libxslt-devel


%description
KBibTeX is a BibTeX editor for TDE to edit bibliographies used with LaTeX.
KBibTeX is released under the GNU Public License (GPL) version 2 or any later version.

+ 9
- 0
redhat/applications/kbiff/kbiff.spec View File

@@ -68,6 +68,15 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kbookreader/kbookreader.spec View File

@@ -66,6 +66,15 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kcmautostart/kcmautostart.spec View File

@@ -65,6 +65,15 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 6
- 0
redhat/applications/kcpuload/kcpuload.spec View File

@@ -66,6 +66,12 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kdirstat/kdirstat.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kiosktool/kiosktool.spec View File

@@ -68,6 +68,15 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 12
- 0
redhat/applications/kkbswitch/kkbswitch.spec View File

@@ -65,6 +65,18 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# XKBFILES support
BuildRequires: libxkbfile-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 6
- 0
redhat/applications/klcddimmer/klcddimmer.spec View File

@@ -65,6 +65,12 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/knetload/knetload.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/knetstats/knetstats.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/knights/knights.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/knmap/knmap.spec View File

@@ -67,6 +67,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/knutclient/knutclient.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 51
- 0
redhat/applications/konversation/konversation.spec View File

@@ -65,6 +65,16 @@ BuildRequires: cmake >= 2.8
BuildRequires: gcc-c++
BuildRequires: pkgconfig

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel


# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files
@@ -94,6 +104,47 @@ BuildRequires: libXi-devel
BuildRequires: libXi6-devel
%endif

# XSCREENSAVER support
# RHEL 4: disabled
# RHEL 5: available in centos-extras
# RHEL 6: available in EPEL
# RHEL 7: available in NUX
%if 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion} || 0%{?rhel} >= 5 || 0%{?suse_version}
%define with_xscreensaver 1

%if 0%{?fedora} || 0%{?rhel} >= 5
BuildRequires: libXScrnSaver-devel
BuildRequires: xscreensaver
BuildRequires: xscreensaver-base
BuildRequires: xscreensaver-extras
%if 0%{?fedora}
BuildRequires: xscreensaver-extras-base
%endif
BuildRequires: xscreensaver-gl-base
BuildRequires: xscreensaver-gl-extras
%endif

%if 0%{?suse_version}
BuildRequires: libXScrnSaver-devel
BuildRequires: xscreensaver
BuildRequires: xscreensaver-data
BuildRequires: xscreensaver-data-extra
%endif

%if 0%{?mgaversion} || 0%{?mdkversion}
%if 0%{?mgaversion} >= 4
BuildRequires: %{_lib}xscrnsaver-devel
%else
BuildRequires: %{_lib}xscrnsaver%{?mgaversion:1}-devel
%endif
BuildRequires: xscreensaver
BuildRequires: xscreensaver-base
BuildRequires: xscreensaver-extrusion
BuildRequires: xscreensaver-gl
%endif
%endif


%description
Konversation is a client for the Internet Relay Chat (IRC) protocol.
It is easy to use and well-suited for novice IRC users, but novice

+ 12
- 0
redhat/applications/kpilot/kpilot.spec View File

@@ -68,6 +68,18 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# ICAL support
BuildRequires: libical-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 6
- 0
redhat/applications/ksensors/ksensors.spec View File

@@ -66,6 +66,12 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kshutdown/kshutdown.spec View File

@@ -65,6 +65,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 6
- 0
redhat/applications/ksplash-engine-moodin/ksplash-engine-moodin.spec View File

@@ -66,6 +66,12 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kvkbd/kvkbd.spec View File

@@ -65,6 +65,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/kvpnc/kvpnc.spec View File

@@ -68,6 +68,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 6
- 0
redhat/applications/mplayerthumbs/mplayerthumbs.spec View File

@@ -65,6 +65,12 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/potracegui/potracegui.spec View File

@@ -65,6 +65,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/tdeio-ftps/tdeio-ftps.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/tdeio-sword/tdeio-sword.spec View File

@@ -71,6 +71,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/tdeio-umountwrapper/tdeio-umountwrapper.spec View File

@@ -70,6 +70,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/tdesudo/tdesudo.spec View File

@@ -65,6 +65,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/tdmtheme/tdmtheme.spec View File

@@ -66,6 +66,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/applications/yakuake/yakuake.spec View File

@@ -65,6 +65,15 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: fdupes

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# SUSE desktop files utility
%if 0%{?suse_version}
BuildRequires: update-desktop-files

+ 9
- 0
redhat/extras/trinity-filesystem/trinity-filesystem-14.0.0.spec View File

@@ -117,6 +117,11 @@ This package installs the Trinity directory structure.
%dir %{tde_datadir}/services
%dir %{tde_datadir}/services/*
%dir %{tde_datadir}/servicetypes
%dir %{tde_datadir}/servicetypes/share
%dir %{tde_datadir}/servicetypes/share/X11
%dir %{tde_datadir}/servicetypes/share/X11/xkb
%dir %{tde_datadir}/servicetypes/share/X11/xkb/symbols

%dir %{tde_datadir}/wallpapers


@@ -205,6 +210,7 @@ This package installs the Trinity directory structure.
%__install -d -m 755 %{?buildroot}%{tde_datadir}/services
%__install -d -m 755 %{?buildroot}%{tde_datadir}/services/tdeconfiguredialog
%__install -d -m 755 %{?buildroot}%{tde_datadir}/servicetypes
%__install -d -m 755 %{?buildroot}%{tde_datadir}/servicetypes/share/X11/xkb/symbols

%__install -d -m 755 %{?buildroot}%{tde_datadir}/wallpapers

@@ -535,6 +541,7 @@ done
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/fi/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/fo/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/fr/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/fy/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/ga/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/gl/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/gu/LC_MESSAGES/
@@ -547,11 +554,13 @@ done
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/it/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/ja/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/ka/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/kk/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/km/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/ko/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/ku/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/lo/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/lt/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/lv/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/mk/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/mr/LC_MESSAGES/
%__install -d -m 755 %{?buildroot}%{tde_datadir}/locale/ms/LC_MESSAGES/

+ 9
- 0
redhat/main/tdeadmin/tdeadmin.spec View File

@@ -87,6 +87,15 @@ BuildRequires: update-desktop-files
BuildRequires: brp-check-trinity
%endif

# ACL support
BuildRequires: libacl-devel

# IDN support
BuildRequires: libidn-devel

# OPENSSL support
BuildRequires: openssl-devel

# RPM support
BuildRequires: rpm-devel


Loading…
Cancel
Save