RPM: update packages for PCLinuxOS 2018

pull/5/head
François Andriot 4 years ago
parent ce92126dee
commit 8d17db2e09
  1. 44
      redhat/Makefile.r14
  2. 5
      redhat/applications/bibletime/bibletime-14.0.0.spec
  3. 6
      redhat/applications/digikam/digikam-14.0.0.spec
  4. 6
      redhat/applications/kcmldapcontroller/kcmldapcontroller-14.0.0.spec
  5. 19
      redhat/applications/koffice/koffice-14.0.0.spec
  6. 5
      redhat/applications/kopete-otr/kopete-otr-14.0.0.spec
  7. 8
      redhat/applications/kstreamripper/kstreamripper-14.0.0.spec
  8. 2
      redhat/applications/kvirc/kvirc-14.0.0.spec
  9. 4
      redhat/applications/piklab/piklab-14.0.0.spec
  10. 3
      redhat/applications/qalculate-tde/qalculate-tde.spec
  11. 5
      redhat/applications/tdeio-sword/tdeio-sword-14.0.0.spec
  12. 2
      redhat/applications/tdenetworkmanager/tdenetworkmanager-14.0.0.spec
  13. 2
      redhat/applications/tderadio/tderadio-14.0.0.spec
  14. 2
      redhat/build/configure_repository.sh
  15. 2
      redhat/build/gather_rpm_sources.sh
  16. 6
      redhat/build/get_rpm_package_name.sh
  17. 2
      redhat/build/get_source_files.sh
  18. 2
      redhat/buildenv.sh
  19. 4
      redhat/docker/build.sh
  20. 17
      redhat/docker/el6/Dockerfile.i686
  21. 17
      redhat/docker/el6/Dockerfile.x86_64
  22. 2
      redhat/docker/el6/packages.trinity
  23. 2
      redhat/docker/el7/Dockerfile.x86_64
  24. 9
      redhat/docker/el7/packages
  25. 6
      redhat/docker/f28/Dockerfile.i686
  26. 3
      redhat/docker/f28/Dockerfile.x86_64
  27. 1
      redhat/docker/f28/packages
  28. 2
      redhat/docker/mga6/Dockerfile.i686
  29. 2
      redhat/docker/mga6/Dockerfile.x86_64
  30. 2
      redhat/docker/mga6/packages.i686
  31. 1
      redhat/docker/mga6/packages.x86_64
  32. 2
      redhat/docker/oss150/Dockerfile.x86_64
  33. 4
      redhat/docker/oss150/packages
  34. 2
      redhat/docker/oss423/Dockerfile.x86_64
  35. 1
      redhat/docker/oss423/packages
  36. 2
      redhat/docker/osstw/Dockerfile.i686
  37. 2
      redhat/docker/osstw/Dockerfile.x86_64
  38. 4
      redhat/docker/osstw/packages
  39. 6
      redhat/docker/pclinuxos/Dockerfile.x86_64
  40. 8
      redhat/docker/pclinuxos/packages.x86_64
  41. 4
      redhat/docker/pclinuxos/rpmmacros
  42. 5
      redhat/docker/run.sh
  43. 2
      redhat/extras/fileshareset/fileshareset.spec
  44. 2
      redhat/libraries/kipi-plugins/kipi-plugins.spec
  45. 2
      redhat/libraries/libkdcraw/libkdcraw-14.0.0.spec
  46. 2
      redhat/libraries/libkipi/libkipi-14.0.0.spec
  47. 5
      redhat/main/tdebase/pamd.kcheckpass-trinity.pclos2018
  48. 7
      redhat/main/tdebase/pamd.kdm-trinity-np.pclos2018
  49. 8
      redhat/main/tdebase/pamd.kdm-trinity.pclos2018
  50. 5
      redhat/main/tdebase/pamd.kscreensaver-trinity.pclos2018
  51. 1
      redhat/main/tdebase/tdebase-14.0.0.spec
  52. 5
      redhat/main/tdebindings/tdebindings-14.0.0.spec
  53. 2
      redhat/main/tdegraphics/tdegraphics-14.0.0.spec
  54. 5
      redhat/notes.txt

@ -1,7 +1,7 @@
SHELL := /bin/bash
PACKAGING_DIR := $(shell cd ..; pwd)
PATH := $(PATH):$(shell pwd)/build
TDE_VERSION := 14.0.4
TDE_VERSION := 14.0.5
DIST := $(shell rpm -E %dist)
buildpkg = \
@ -108,6 +108,7 @@ tdegraphics: tdebase poppler cmake lcms
$(call buildpkg,main/tdegraphics)
tdelibs: tqt3 tqtinterface arts dbus-tqt dbus-1-tqt cmake avahi-tqt fileshareset trinity-filesystem libart_lgpl file
[ -x /usr/libexec/utempter/utempter ] && sudo chmod a+r /usr/libexec/utempter/utempter || :
$(call buildpkg,main/tdelibs)
tdemultimedia: tdebase akode
@ -166,8 +167,8 @@ ifneq ($(wildcard /boot/vmlinuz*.el7*),)
endif
esound:
# Build on Mageia and CentOS >= 7, Fedora >= 23, Opensuse >= 15.0
ifneq (,$(filter $(DIST),.mga .el7 .fc2 .oss150 .osstw))
# Build on Mageia, Fedora >= 23, Opensuse >= 15.0
ifneq (,$(filter $(DIST),.mga5 .mga6 .fc23 .fc24 .fc25 .fc26 .fc27 .oss150 .osstw))
$(call buildpkg,3rdparty/esound)
endif
@ -190,8 +191,8 @@ ifneq (,$(filter $(DIST),.el5))
endif
gnuchess:
# Build on CentOS 5, CentOS 7
ifneq (,$(filter $(DIST),.el5 .el7))
# Build on CentOS 5
ifneq (,$(filter $(DIST),.el5))
$(call buildpkg,3rdparty/gnuchess)
endif
@ -210,8 +211,8 @@ endif
endif
lcms:
# Build on EL7, OSSTW
ifneq (,$(filter $(DIST),.el7 .osstw))
# Build on EL7, OSS150, OSSTW
ifneq (,$(filter $(DIST),.el7 .oss150 .osstw))
$(call buildpkg,3rdparty/lcms)
endif
@ -252,8 +253,8 @@ ifneq (,$(filter $(DIST),.oss131 .oss132 .oss421 .oss422 .oss423 .oss150 .osstw)
endif
pcsc-perl:
# Build on CentOS
ifneq (,$(filter $(DIST),.el5 .el6 .el7))
# Build on CentOS 5
ifneq (,$(filter $(DIST),.el5))
$(call buildpkg,3rdparty/pcsc-perl)
endif
@ -310,7 +311,7 @@ endif
wv2:
# Do NOT build on Mageia or openSUSE or PCLINUXOS
ifeq (,$(filter $(DIST), .mga5 .mga6 .oss421 .oss422 .oss423 .oss150 .osstw .pclos))
ifeq (,$(filter $(DIST), .mga5 .mga6 .oss421 .oss422 .oss423 .oss150 .osstw .pclos .pclos2018))
$(call buildpkg,3rdparty/wv2)
endif
@ -337,10 +338,7 @@ libksquirrel: tdelibs
$(call buildpkg,libraries/libksquirrel)
libtdeldap: tqtinterface
# Do NOT build on PCLOS
ifeq ($(wildcard /etc/pclinuxos-release),)
$(call buildpkg,libraries/libtdeldap)
endif
libtqt-perl: tqtinterface
$(call buildpkg,libraries/libtqt-perl)
@ -452,20 +450,20 @@ kcmautostart: tdebase
$(call buildpkg,applications/kcmautostart)
kcmldap: tdebase libtdeldap
# Do NOT build on CentOS 5, PCLinuxOS
ifeq (,$(filter $(DIST),.el5 .pclos))
# Do NOT build on CentOS 5
ifeq (,$(filter $(DIST),.el5))
$(call buildpkg,applications/kcmldap)
endif
kcmldapcontroller: tdebase kcmldap
# Do NOT build on CentOS 5, PCLinuxOS
ifeq (,$(filter $(DIST),.el5 .pclos))
# Do NOT build on CentOS 5
ifeq (,$(filter $(DIST),.el5))
$(call buildpkg,applications/kcmldapcontroller)
endif
kcmldapmanager: tdebase kcmldap
# Do NOT build on CentOS 5, PCLinuxOS
ifeq (,$(filter $(DIST),.el5 .pclos))
# Do NOT build on CentOS 5
ifeq (,$(filter $(DIST),.el5))
$(call buildpkg,applications/kcmldapmanager)
endif
@ -491,8 +489,8 @@ keep: tdebase rdiff-backup
$(call buildpkg,applications/keep)
kerberostray: tdebase
# Do NOT build on CentOS 5, PCLinuxOS
ifeq (,$(filter $(DIST),.el5 .pclos))
# Do NOT build on CentOS 5
ifeq (,$(filter $(DIST),.el5))
$(call buildpkg,applications/kerberostray)
endif
@ -578,7 +576,9 @@ kooldock: tdebase
$(call buildpkg,applications/kooldock)
kopete-otr: tdebase tdenetwork
ifeq (,$(filter $(DIST),.pclos2018))
$(call buildpkg,applications/kopete-otr)
endif
kpicosim: tdebase
$(call buildpkg,applications/kpicosim)
@ -850,7 +850,7 @@ mathemagics:
$(call buildpkg,extras/mathemagics)
pan: gmime intltool
ifeq (,$(filter $(DIST),.el5 .oss150 .osstw)))
ifeq (,$(filter $(DIST),.el5 .oss150 .osstw))
$(call buildpkg,3rdparty/pan)
endif

@ -15,6 +15,11 @@
# Please submit bugfixes or comments via http://www.trinitydesktop.org/
#
# Required for PCLinuxOS: removes the ldflag '--no-undefined'
%if 0%{?pclinuxos}
%define _disable_ld_no_undefined 1
%endif
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""

@ -84,7 +84,7 @@ BuildRequires: brp-check-trinity
%endif
# LCMS support
%if 0%{?suse_version}
%if 0%{?suse_version} || 0%{?rhel} >= 7
BuildRequires: liblcms-devel
%else
BuildRequires: lcms-devel
@ -308,9 +308,9 @@ Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
%lang(nl) %{tde_tdedocdir}/HTML/nl/digikam/
%lang(nl) %{tde_tdedocdir}/HTML/nl/showfoto/
%lang(pt_BR) %{tde_tdedocdir}/HTML/pt_BR/digikam/
#%lang(pt_BR) %{tde_tdedocdir}/HTML/pt_BR/showfoto/
#lang(pt_BR) %{tde_tdedocdir}/HTML/pt_BR/showfoto/
%lang(ru) %{tde_tdedocdir}/HTML/ru/digikam/
#%lang(ru) %{tde_tdedocdir}/HTML/ru/showfoto/
#lang(ru) %{tde_tdedocdir}/HTML/ru/showfoto/
%lang(sv) %{tde_tdedocdir}/HTML/sv/digikam/
%lang(sv) %{tde_tdedocdir}/HTML/sv/showfoto/

@ -134,8 +134,10 @@ This is a TDE control center module to manage users, groups, and machines in Ker
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING
%{tde_bindir}/primaryrccertupdater
%if 0%{?pclinuxos} == 0
%{tde_libdir}/slapi-acl-manager.la
%{tde_libdir}/slapi-acl-manager.so
%endif
%{tde_tdelibdir}/kcm_ldapcontroller.la
%{tde_tdelibdir}/kcm_ldapcontroller.so
%{tde_tdeappdir}/ldapcontroller.desktop
@ -155,6 +157,10 @@ This is a TDE control center module to manage users, groups, and machines in Ker
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%if 0%{?pclinuxos}
%__rm -rf acl-updater
%endif
%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
%__make -f "admin/Makefile.common"

@ -113,16 +113,27 @@ BuildRequires: OpenEXR-devel
BuildRequires: libexif-devel
BuildRequires: readline-devel
# LCMS support
%if 0%{?suse_version} || 0%{?rhel} >= 7
BuildRequires: liblcms-devel
%else
BuildRequires: lcms-devel
%endif
# LCMS2 support
%if 0%{?suse_version}
BuildRequires: libbz2-devel
BuildRequires: liblcms-devel
BuildRequires: liblcms2-devel
%endif
# BZIP2 support
%if 0%{?suse_version}
BuildRequires: libbz2-devel
%else
BuildRequires: bzip2-devel
BuildRequires: lcms-devel
%endif
# PAPER support
BuildRequires: libpaper-devel
%endif
# RUBY support
%if 0%{?with_ruby}

@ -33,9 +33,10 @@
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
# Required for Mageia 2: removes the ldflag '--no-undefined'
# Required for Mageia 6: removes the ldflag '--no-undefined'
%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
%define _disable_ld_no_undefined 1
%endif
Name: trinity-%{tde_pkg}
Epoch: %{tde_epoch}

@ -108,14 +108,6 @@ you with managing/ripping your preferred streams.
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
# Force running 'tmoc' on all header files
for h in "src/"*".h"; do
moc="${h/.h/.moc}"
tmoc "${h}" -o "${moc}"
cpp="${h/.h/.cpp}"
echo "#include \"${moc##*/}\"" >>"${cpp}"
done
export QTDIR=/usr
python2 /usr/bin/scons configure prefix="%{_prefix}"
python2 /usr/bin/scons %{?_smp_mflags}

@ -181,7 +181,7 @@ export PATH="%{tde_bindir}:${PATH}"
%__make symlinks -C src/kvilib/build
%__make symlinks -C src/kvirc/build
%if 0%{?mgaversion} >= 6
%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
%__sed -i "src/modules/"*"/Makefile" -e "s|-Wl,--no-undefined||"
%endif

@ -140,13 +140,13 @@ export PATH="%{tde_bindir}:${PATH}"
--disable-libreadline \
%endif
%if 0%{?mgaversion} >= 6
%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
touch "src/devices/pic/xml_data/Makefile.in" "src/devices/mem24/xml_data/Makefile.in"
%endif
%__make %{?_smp_mflags}
%if 0%{?mgaversion} >= 6
%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
touch "src/devices/pic/xml_data/Makefile.in" "src/devices/mem24/xml_data/Makefile.in"
%endif

@ -71,6 +71,9 @@ BuildRequires: libqalculate-devel >= 0.9.6
%if 0%{?suse_version} == 1330 || 0%{?suse_version} >= 1500
BuildRequires: cln-devel
%endif
%if 0%{?pclinuxos} >= 2018
BuildRequires: libcln-devel
%endif
# SUSE desktop files utility
%if 0%{?suse_version}

@ -15,6 +15,11 @@
# Please submit bugfixes or comments via http://www.trinitydesktop.org/
#
# Required for PCLinuxOS: removes the ldflag '--no-undefined'
%if 0%{?pclinuxos} >= 2018
%define _disable_ld_no_undefined 1
%endif
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""

@ -93,8 +93,10 @@ Requires: NetworkManager-gnome
Requires: networkmanager
%endif
%if 0%{?rhel} || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
%if 0%{?pclinuxos} == 0
BuildRequires: NetworkManager-glib-devel
%endif
%endif
%if 0%{?suse_version}
BuildRequires: NetworkManager-devel
Requires: NetworkManager

@ -182,7 +182,7 @@ export PATH="%{tde_bindir}:${PATH}"
--enable-alsa \
--enable-oss
%if 0%{?mgaversion} >= 6
%if 0%{?mgaversion} >= 6 || 0%{?pclinuxos} >= 2018
%__sed -i "tderadio3/plugins/"*"/Makefile" -e "s|-Wl,--no-undefined||"
%endif

@ -43,5 +43,5 @@ fi
if [ -x "/usr/bin/apt-get" ]; then
[ ! -L "${RPMDIR}/RPMS.${ARCH}" ] && ln -sf "${ARCH}" "${RPMDIR}/RPMS.${ARCH}"
[ ! -L "${RPMDIR}/RPMS.noarch" ] && ln -sf "noarch" "${RPMDIR}/RPMS.noarch"
echo "rpm file:${RPMDIR%/*} ${RPMDIR##*/} ${ARCH} noarch" >"/etc/apt/sources.list.d/rpmbuild.list"
echo "rpm file:${RPMDIR%/*} ${RPMDIR##*/} ${ARCH} noarch" | sudo tee "/etc/apt/sources.list.d/rpmbuild.list"
fi

@ -6,7 +6,7 @@
PKGNAME="${1%/}"
PKGNAME="${PKGNAME##*/}"
TDE_VERSION="${2:-14.0.4}"
TDE_VERSION="${2:-14.0.5}"
TARGETDIR="${3:-/tmp/${PKGNAME}-${TDE_VERSION}}"
DIST="$4"

@ -21,8 +21,6 @@ case "${PKGNAME}" in
"trinity-"*) PREFIX="";;
# Most TDE dependencies have no prefix
"avahi-tqt"|"dbus-tqt"|"dbus-1-tqt"|"libart-lgpl"|"libcaldav"|"libcarddav"|"python-tqt"|"sip4-tqt"|"qt3"|"tqscintilla"|"tqt3"|"tqtinterface"|"tqca"|"tqca-tls") PREFIX="";;
# Most TDE libraries have no prefix
#"libkdcraw") PREFIX="";;
# 3rd party dependencies
"cscope"|"dirmngr"|"esound"|"exempi"|"file"|"fileshareset"|"gmime"|"hk_classes"|"intltool"|"lcms"|"mp4v2"|"python-qt3"|"rdesktop"|"recode"|"rdiff-backup"|"sword"|"tar") PREFIX="";;
# Extra build stuff
@ -46,7 +44,7 @@ case "${PKGNAME}" in
"dbus-tqt") PKGRUNTIME="${lib}dbus-tqt-1-0";;
"dbus-1-tqt") PKGRUNTIME="${lib}dbus-1-tqt0";;
"digikam") PKGRUNTIME="digikam-i18n";;
"esound") PKGRUNTIME="libesd0";;
"esound") PKGRUNTIME="${lib}esd0";;
"imlib1") PKGRUNTIME="${lib}Imlib1";;
"knetworkmanager8") PKGRUNTIME="knetworkmanager";;
"koffice") PKGRUNTIME="koffice-suite";;
@ -86,7 +84,7 @@ if [ -n "${DEVEL}" ]; then
# Some other packags NOT having development package
case "${PKGNAME}" in
"autoconf"|"automake"|"cmake"|"cscope"|"hal-info"|"lilypond"|"m4"|"mftrace"|"pcsc-perl"|"rdesktop"|"recode"|"rdiff-backup"|"torsocks") exit 0;;
"autoconf"|"automake"|"cmake"|"cscope"|"gnuchess"|"hal-info"|"lilypond"|"m4"|"mftrace"|"pcsc-perl"|"rdesktop"|"recode"|"rdiff-backup"|"torsocks") exit 0;;
"tqca-tls"|"tdeadmin"|"tdetoys"|"tde-i18n"*|"tdeaddons"|"tdeartwork"|"libtqt-perl"|"kipi-plugins") exit 0;;
esac

@ -1,7 +1,7 @@
#!/bin/bash
PKGNAME="${1##*/}"
TDE_VERSION="${2:-14.0.4}"
TDE_VERSION="${2:-14.0.5}"
DIST="$3"
[ -z "${PKGNAME}" ] && echo "You must specify a package name !" && exit 1

@ -3,7 +3,7 @@
# This file can be sourced in your .bashrc
TDE_BASEDIR=~/tde
[ -z "${TDE_VERSION}" ] && TDE_VERSION="14.0.4"
[ -z "${TDE_VERSION}" ] && TDE_VERSION="14.0.5"
TDE_GITBASESRC=${TDE_BASEDIR}/tde_master
TDE_GITBASEPKG=${TDE_BASEDIR}/tde-packaging/redhat
TDE_TARBALLS=${TDE_BASEDIR}/tde-tarballs/${TDE_VERSION}

@ -4,10 +4,10 @@ DISTRIB="$1"
TDE_VERSION="$2"
ARCH="$3"
[ -z "${TDE_VERSION}" ] && TDE_VERSION="14.0.4"
[ -z "${TDE_VERSION}" ] && TDE_VERSION="14.0.5"
[ -z "${ARCH}" ] && ARCH="x86_64"
IMAGE="trinity.${DISTRIB}.${ARCH}:${TDE_VERSION}"
docker rmi -f "${IMAGE}"
#docker rmi -f "${IMAGE}"
docker build -t "${IMAGE}" -f "${DISTRIB}/Dockerfile.${ARCH}" --build-arg TDE_VERSION="${TDE_VERSION}" --build-arg ARCH="${ARCH}" "${DISTRIB}"

@ -1,22 +1,25 @@
FROM centos32:6
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=i686
RUN echo "proxy=http://proxy:3128" >>/etc/yum.conf
# Add EPEL repository
RUN yum install -y epel-release
RUN yum -y install epel-release
# Add NUX repository
RUN rpm -Uvh http://li.nux.ro/download/nux/dextop/el6/x86_64/nux-dextop-release-0-2.el6.nux.noarch.rpm
# Install Trinity build dependencies
ADD packages.trinity /etc/yum.repos.d/packages
RUN setarch ${ARCH} yum update -y
RUN setarch ${ARCH} yum install -y $(</etc/yum.repos.d/packages) || :
ADD packages.trinity /packages
RUN setarch ${ARCH} yum -y update
RUN setarch ${ARCH} yum -y install $(</packages)
# Add YUM repository for locally built packages
ADD rpmbuild.repo /etc/yum.repos.d/rpmbuild.repo
RUN sed -i "/etc/yum.repos.d/rpmbuild.repo" -e "s|\${ARCH}|${ARCH}|g" -e "s|\${TDE_VERSION}|${TDE_VERSION}|g"
WORKDIR /etc/yum.repos.d
ADD rpmbuild.repo rpmbuild.repo
RUN sed -i "rpmbuild.repo" -e "s|\${ARCH}|${ARCH}|g" -e "s|\${TDE_VERSION}|${TDE_VERSION}|g"
# Add non-root user to build packages
RUN useradd -m -s /bin/bash -u 1000 trinity

@ -1,22 +1,25 @@
FROM centos:6
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
RUN echo "proxy=http://proxy:3128" >>/etc/yum.conf
# Add EPEL repository
RUN yum install -y epel-release
RUN yum -y install epel-release
# Add NUX repository
RUN rpm -Uvh http://li.nux.ro/download/nux/dextop/el6/x86_64/nux-dextop-release-0-2.el6.nux.noarch.rpm
# Install Trinity build dependencies
ADD packages.trinity /etc/yum.repos.d/packages
RUN yum update -y
RUN yum install -y $(</etc/yum.repos.d/packages) || :
ADD packages.trinity /packages
RUN yum -y update
RUN yum -y install $(</packages)
# Add YUM repository for locally built packages
ADD rpmbuild.repo /etc/yum.repos.d/rpmbuild.repo
RUN sed -i "/etc/yum.repos.d/rpmbuild.repo" -e "s|\${ARCH}|${ARCH}|g" -e "s|\${TDE_VERSION}|${TDE_VERSION}|g"
WORKDIR /etc/yum.repos.d
ADD rpmbuild.repo rpmbuild.repo
RUN sed -i "rpmbuild.repo" -e "s|\${ARCH}|${ARCH}|g" -e "s|\${TDE_VERSION}|${TDE_VERSION}|g"
# Add non-root user to build packages
RUN useradd -m -s /bin/bash -u 1000 trinity

@ -50,6 +50,7 @@ gcc-gfortran
gcc-java
gettext-devel
glib-devel
gmime-devel
gmp-devel
gnokii-devel
gperf
@ -190,6 +191,7 @@ taglib-devel
tar
texinfo
texlive-utils
torsocks
transfig
udisks-devel
unixODBC-devel

@ -1,6 +1,6 @@
FROM centos:7
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
# Add EPEL repository

@ -14,6 +14,8 @@ cdparanoia
cdparanoia-devel
chmlib-devel
chrpath
clamav
clamav-devel
clucene-core-devel
cmake
cpp
@ -28,6 +30,7 @@ djvulibre-devel
doxygen
emacs
esound-devel
exempi-devel
exiv2-devel
fdupes
ffmpeg-devel
@ -43,6 +46,7 @@ gcc-c++
gcc-gfortran
gettext-devel
glib-devel
gmime-devel
gmp-devel
gperf
gpgme-devel
@ -64,6 +68,8 @@ icu
ImageMagick-devel
imake
imlib-devel
imlib2-devel
intltool
jack-audio-connection-kit-devel
jasper-devel
java-1.7.0-openjdk-devel
@ -100,6 +106,7 @@ libofx-devel
libogg-devel
libotr-devel
libpaper-devel
libqalculate-devel
libraw1394-devel
librsvg2-tools
libsamplerate-devel
@ -159,6 +166,7 @@ poppler-devel
postgresql-devel
pth-devel
pulseaudio-libs-devel
qt-devel
readline-devel
recode
redhat-rpm-config
@ -181,6 +189,7 @@ t1utils
taglib-devel
tar
texinfo
torsocks
transfig
unixODBC-devel
usbutils

@ -1,9 +1,9 @@
FROM fedora32:28
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=i686
RUN echo "proxy=http://192.168.111.249:3128" >>"/etc/yum.conf"
RUN echo "proxy=http://proxy:3128" >>"/etc/dnf.conf"
# Add RPMFUSION repository
RUN rpm -Uvh https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-28.noarch.rpm
@ -11,7 +11,7 @@ RUN rpm -Uvh https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-
# Install Trinity build dependencies
RUN setarch i686 dnf update -y
ADD packages /packages
#RUN setarch i686 dnf install -y texlive-base
RUN touch /var/lib/rpm/*
RUN setarch i686 dnf install -y $(</packages)
# Add YUM repository for locally built packages

@ -1,6 +1,6 @@
FROM fedora:28
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
RUN echo "proxy=http://proxy:3128" >>"/etc/dnf.conf"
@ -11,6 +11,7 @@ RUN rpm -Uvh https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-
# Install Trinity build dependencies
RUN dnf update -y
ADD packages /packages
RUN touch /var/lib/rpm/*
RUN dnf install -y $(</packages)
# Add YUM repository for locally built packages

@ -35,6 +35,7 @@ esound-devel
exempi-devel
exiv2-devel
fdupes
fedora-rpm-macros
ffmpeg-devel
fftw-devel
file-devel

@ -1,6 +1,6 @@
FROM mageia32:6
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=i686
# Reset URPMI repositories to default

@ -1,6 +1,6 @@
FROM mageia:6
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
# Reset URPMI repositories to default

@ -95,6 +95,7 @@ libsane1-devel
libt1lib-devel
libtiff-devel
libtwolame-devel
libutempter
libudev-devel
libusb1.0-devel
libutempter-devel
@ -186,6 +187,7 @@ notification-daemon
ocaml
OpenEXR-devel
openldap-devel
openldap-servers-devel
opensc
openslp-devel
opensp-devel

@ -186,6 +186,7 @@ notification-daemon
ocaml
OpenEXR-devel
openldap-devel
openldap-servers-devel
opensc
openslp-devel
opensp-devel

@ -1,6 +1,6 @@
FROM opensuse:15.0
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
# Add PACKMAN repository

@ -60,6 +60,7 @@ intltool
java-1_8_0-openjdk-devel
less
libacl-devel
libao-devel
libart_lgpl-devel
libavahi-devel
libavcodec-devel
@ -85,6 +86,7 @@ libidn-devel
libiw-devel
libjack-devel
libjasper-devel
liblcms-devel
liblo-devel
liblrdf-devel
libmad-devel
@ -99,6 +101,7 @@ libnjb-devel
libnsl-devel
libofx-devel
libotr-devel
libpaper-devel
libpisock-devel
libpng16-devel
libpoppler-devel
@ -148,7 +151,6 @@ pciutils-devel
pcre-devel
pcsc-lite-devel
pkcs11-helper-devel
pkgconfig(ao)
postgresql
postgresql-devel
python-devel

@ -1,6 +1,6 @@
FROM opensuse:42.3
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
# Add PACKMAN repository

@ -87,6 +87,7 @@ libiw-devel
libjack-devel
libjasper-devel
liblcms-devel
liblcms2-devel
liblo-devel
liblrdf-devel
libmad-devel

@ -1,6 +1,6 @@
FROM opensuse32:tumbleweed
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=i686
# Add PACKMAN repository

@ -1,6 +1,6 @@
FROM opensuse:tumbleweed
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
# Add PACKMAN repository

@ -102,6 +102,7 @@ libnsl-devel
libofx-devel
libopenssl-devel
libotr-devel
libpaper-devel
libpisock-devel
libpng16-devel
libpoppler-devel
@ -127,6 +128,7 @@ libvisual-devel
libvorbis-devel
libwmf-devel
libwpd-devel
libXaw-devel
libXdmcp-devel
libxine-devel
libxkbfile-devel
@ -135,6 +137,7 @@ libxslt-devel
libXss-devel
libXt-devel
libXtst-devel
libXv-devel
libXxf86dga-devel
lilo
lirc-devel
@ -144,6 +147,7 @@ meanwhile-devel
Mesa-devel
Mesa-libGL-devel
mozilla-nspr-devel
net-tools
net-tools-deprecated
NetworkManager-devel
ocaml

@ -1,6 +1,6 @@
FROM pclinuxos:2017
ARG TDE_VERSION=14.0.4
ARG TDE_VERSION=14.0.5
ARG ARCH=x86_64
# Update distribution
@ -8,8 +8,8 @@ RUN apt-get -y update
RUN apt-get -y dist-upgrade
# Install Trinity build dependencies
ADD packages.${ARCH} /etc/apt/packages
RUN apt-get -y install $(</etc/apt/packages)
ADD packages.${ARCH} /packages
RUN apt-get -y install $(</packages)
# Add rpmbuild repositories
ADD rpmbuild.list /etc/apt/sources.list.d/rpmbuild.list

@ -43,12 +43,15 @@ htdig
ImageMagick-devel
imake
java-devel
lcms-devel
lib64cryptsetup-devel
lib64dvdread-devel
lib64exiv2-devel
lib64gif-devel
lib64idn-devel
lib64inotifytools-devel
lib64iw29-devel
lib64nm-devel
lib64mpcdec-devel
lib64OpenSP5-devel
lib64pkcs11-helper-devel
@ -86,12 +89,11 @@ libmp4v2-devel
libmtp-devel
libmusicbrainz-devel
libnjb-devel
libnm-util-devel
libofa-devel
libofx-devel
libotr-devel
libpaper-devel
libpng-devel
lib64png1.6-devel
libpqxx-devel
libpthread-stubs
libpulseaudio-devel
@ -104,6 +106,7 @@ libsm-devel
libt1lib-devel
libtheora-devel
libudev-devel
libuuid-devel
libv4l-devel
libvisual-devel
libvorbis-devel
@ -131,7 +134,6 @@ mysql-devel
nas-devel
neon-devel
net-snmp-devel
NetworkManager-glib-devel
ocaml
OpenEXR-devel
openldap-devel

@ -1,4 +1,4 @@
%dist .pclos2017
%dist .pclos2018
%_smp_mflags -j8
%jobs 8
%pclinuxos 2017
%pclinuxos 2018

@ -4,7 +4,7 @@ DISTRIB="$1"
TDE_VERSION="$2"
ARCH="$3"
[ -z "${TDE_VERSION}" ] && TDE_VERSION="14.0.4"
[ -z "${TDE_VERSION}" ] && TDE_VERSION="14.0.5"
[ -z "${ARCH}" ] && ARCH="x86_64"
IMAGE="trinity.${DISTRIB}.${ARCH}:${TDE_VERSION}"
@ -14,8 +14,9 @@ mkdir -p "${HOME}/rpmbuild/RPMS/RPMS${DIST}.tde-${TDE_VERSION}"
mkdir -p "${HOME}/rpmbuild/SRPMS/SRPMS${DIST}.tde-${TDE_VERSION}"
mkdir -p "/dev/shm/docker"
docker run -t -i --rm \
docker run -t -i --rm --privileged \
-h "${IMAGE}" \
--name "${IMAGE//:/-}" \
-v /dev/shm/docker:/tmp:z \
-u trinity \
-e TMPPATH=/tmp \

@ -20,7 +20,7 @@
#email : Uwe.Gansert@suse.de
%if 0%{?fedora} >= 27
%define debug_package %{nil}
%global debug_package %{nil}
%endif
Name: fileshareset

@ -99,7 +99,7 @@ BuildRequires: libgpod-devel >= 0.4.2
%endif
# LCMS support
%if 0%{?suse_version}
%if 0%{?suse_version} || 0%{?rhel} >= 7
BuildRequires: liblcms-devel
%else
BuildRequires: lcms-devel

@ -66,7 +66,7 @@ BuildRequires: pkgconfig
BuildRequires: gettext
# LCMS support
%if 0%{?suse_version}
%if 0%{?suse_version} || 0%{?rhel} >= 7
BuildRequires: liblcms-devel
%else
BuildRequires: lcms-devel

@ -73,7 +73,7 @@ BuildRequires: gettext
BuildRequires: gcc-c++
# LCMS support
%if 0%{?suse_version}
%if 0%{?suse_version} || 0%{?rhel} >= 7
BuildRequires: liblcms-devel
%else
BuildRequires: lcms-devel

@ -0,0 +1,5 @@
#%PAM-1.0
auth include system-auth
account include system-auth
password include system-auth
session include system-auth

@ -0,0 +1,7 @@
#%PAM-1.0
auth required pam_env.so
auth required pam_permit.so
account include system-auth
password include system-auth
session include system-auth
session optional pam_console.so

@ -0,0 +1,8 @@
#%PAM-1.0
auth include system-auth
auth required pam_nologin.so
account include system-auth
password include system-auth
session include system-auth
session optional pam_console.so
session required pam_namespace.so

@ -0,0 +1,5 @@
#%PAM-1.0
auth include system-auth
account include system-auth
password include system-auth
session include system-auth

@ -1885,6 +1885,7 @@ group.
%{tde_datadir}/apps/tdeio_info/
%{tde_datadir}/apps/tdeio_man/
%{tde_datadir}/apps/systemview/
%{tde_datadir}/autostart/mediabackend.desktop
%{tde_datadir}/config.kcfg/mediamanagersettings.kcfg
%{tde_datadir}/mimelnk/application/x-smb-server.desktop
%{tde_datadir}/mimelnk/inode/system_directory.desktop

@ -15,6 +15,11 @@
# Please submit bugfixes or comments via http://www.trinitydesktop.org/
#
# Required for PCLinuxOS: removes the ldflag '--no-undefined'
%if 0%{?pclinuxos}
%define _disable_ld_no_undefined 1
%endif
# BUILD WARNING:
# Remove qt-devel and qt3-devel and any kde*-devel on your system !
# Having KDE libraries may cause FTBFS here !

@ -215,7 +215,7 @@ BuildRequires: trinity-poppler-devel >= 0.12
%endif
# LCMS support
%if 0%{?suse_version}
%if 0%{?suse_version} || 0%{?rhel} >= 7
BuildRequires: liblcms-devel
%else
BuildRequires: lcms-devel

@ -28,6 +28,11 @@ Bug in /usr/lib[64]/pkgconfig/ruby.pc : missing "ruby_version:" value
Should be: ruby_version=2.0.0
MAGEIA 6:
if tdegraphics fails because of 'nullptr' undefined:
vi /usr/include/poppler/PDFDoc.h
add '#define nullptr NULL'
CENTOS 4 / CENTOS 5
Some mandatory packages are missing or too old.

Loading…
Cancel
Save