Browse Source

RPM Packaging: updates for 3.5.13.2

tags/r14.0.0
François Andriot 6 years ago
parent
commit
c56eddf6d0
7 changed files with 141 additions and 11 deletions
  1. +29
    -8
      redhat/buildall-sru.sh
  2. +48
    -0
      redhat/dependencies/arts/arts-3.5.13.2-pkgconfig_requires.patch
  3. +3
    -0
      redhat/dependencies/arts/arts-3.5.13.2.spec
  4. +0
    -2
      redhat/packages.fedora
  5. +25
    -0
      redhat/tdelibs/tdelibs-3.5.13.2-fix_arts_include.patch
  6. +3
    -0
      redhat/tdelibs/tdelibs-3.5.13.2.spec
  7. +33
    -1
      redhat/tdemultimedia/tdemultimedia-3.5.13.2-ftbfs.patch

+ 29
- 8
redhat/buildall-sru.sh View File

@@ -139,10 +139,10 @@ grpiui tdeutils
if ! is_installed trinity-desktop; then
grpiu extras/trinity-desktop
eval ${PKGINST} trinity-desktop || exit 1
# Disable trinity repository from here !!!
if [ -r "/etc/yum.repos.d/trinity-3.5.13.repo" ]; then
sed -i "/etc/yum.repos.d/trinity-3.5.13.repo" -e "s|enabled=.*|enabled=0|g"
fi
fi
# Disable trinity repository from here !!!
if [ -r "/etc/yum.repos.d/trinity-3.5.13.repo" ]; then
sudo sed -i "/etc/yum.repos.d/trinity-3.5.13.repo" -e "s|enabled=.*|enabled=0|g"
fi

# devel packages
@@ -153,10 +153,10 @@ if ! is_installed trinity-desktop-devel; then
eval ${PKGINST} trinity-desktop-devel || exit 1
fi

# Extra libraries
# 3rd party libraries

## IMLIB1: required for kuickshow
if ! is_installed imlib1-devel; then
if ! is_installed imlib1-devel && ! is_installed imlib-devel; then
grpiu 3rdparty/imlib1
eval ${PKGINST} imlib1-devel || exit 1
fi
@@ -169,17 +169,36 @@ if [ "${DIST:0:4}" != ".mga" ]; then
eval ${PKGINST} wv2-devel || exit 1
fi
fi

## PYTHON-QT3: for Python-stuff
if ! is_installed python-qt3; then
if [ "${DIST:0:3}" = ".el" ] || [ "${DIST:0:3}" = ".fc" ]; then
eval ${PKGINST} qt3-MySQL qt3-ODBC qt3-PostgreSQL
fi
grpiu 3rdparty/python-qt3
eval ${PKGINST} python-qt3-devel || exit 1
fi
if [ "${DIST:0:4}" = ".oss" ]; then

## PCSC-PERL: for smartcardauth
if [ "${DIST:0:4}" = ".oss" ] || [ "${DIST:0:3}" = ".el" ]; then
if ! is_installed pcsc-perl; then
grpiu 3rdparty/pcsc-perl
eval ${PKGINST} pcsc-perl || exit 1
fi
fi

## Lilypond: needed for rosegarden
if [ "${DIST}" = ".el6" ]; then
if ! is_installed mftrace; then
grpiu 3rdparty/mftrace
eval ${PKGINST} mftrace || exit 1
fi
if ! is_installed lilypond; then
grpiu 3rdparty/lilypond
eval ${PKGINST} lilypond || exit 1
fi
fi

# TDE libraries
grpiud libraries/libkdcraw
grpiud libraries/libkexiv2
@@ -258,7 +277,9 @@ grpiui applications/kvirc
grpiui applications/kvkbd
grpiui applications/piklab
grpiui applications/potracegui
grpiui applications/rosegarden
if [ "${DIST}" != ".el4" ] && [ "${DIST}" != ".el5" ]; then
grpiui applications/rosegarden
fi
grpiui applications/smartcardauth
grpiui applications/smb4k
grpiui applications/soundkonverter


+ 48
- 0
redhat/dependencies/arts/arts-3.5.13.2-pkgconfig_requires.patch View File

@@ -0,0 +1,48 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c122548..ad4f028 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -226,6 +226,34 @@ configure_file( config.h.cmake config.h @ONLY )
##### write pkgconfig file ######################
+set( PC_LIB_REQUIRE "" )
+if( WITH_ALSA )
+ list( APPEND PC_LIB_REQUIRE "alsa" )
+endif( WITH_ALSA )
+if( WITH_AUDIOFILE )
+ list( APPEND PC_LIB_REQUIRE "audiofile" )
+endif( WITH_AUDIOFILE )
+if( WITH_VORBIS )
+ list( APPEND PC_LIB_REQUIRE "vorbis" )
+ list( APPEND PC_LIB_REQUIRE "vorbisfile" )
+endif( WITH_VORBIS )
+if( WITH_MAD )
+ list( APPEND PC_LIB_REQUIRE "mad" )
+endif( WITH_MAD )
+if( WITH_ESOUND )
+ list( APPEND PC_LIB_REQUIRE "esound" )
+endif( WITH_ESOUND )
+if( WITH_JACK )
+ list( APPEND PC_LIB_REQUIRE "jack" )
+endif( WITH_JACK )
+
+list( LENGTH PC_LIB_REQUIRE PC_LIB_REQUIRES_FOUND )
+if( PC_LIB_REQUIRES_FOUND GREATER 0 )
+ string( REPLACE ";" " " PC_LIB_REQUIRES "Requires: ${PC_LIB_REQUIRE}" )
+else( )
+ set( PC_LIB_REQUIRES "" )
+endif( )
+
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_EXEC_PREFIX ${EXEC_INSTALL_PREFIX} )
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_INCLUDE_DIR ${INCLUDE_INSTALL_DIR} )
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_LIB_DIR ${LIB_INSTALL_DIR} )
diff --git a/arts.pc.cmake b/arts.pc.cmake
index 2c26a41..77332d2 100644
--- a/arts.pc.cmake
+++ b/arts.pc.cmake
@@ -8,3 +8,4 @@ Description: Soundserver for the Trinity Desktop Environment (TDE)
Version: @ARTS_VERSION@
Libs: -L${libdir}
Cflags: -I${includedir}
+@PC_LIB_REQUIRES@

+ 3
- 0
redhat/dependencies/arts/arts-3.5.13.2.spec View File

@@ -32,6 +32,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
Source1: kcmartsrc-pulseaudio

Patch0: arts-3.5.13.2-pkgconfig_requires.patch

BuildRequires: cmake >= 2.8
BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
BuildRequires: audiofile-devel
@@ -194,6 +196,7 @@ Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}

%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
%patch0 -p1 -b .pkgconfig


%build


+ 0
- 2
redhat/packages.fedora View File

@@ -125,7 +125,6 @@ pilot-link-devel
poppler-devel
pth-devel
pulseaudio-libs-devel
PyQt-devel
redhat-rpm-config
rpm-build
ruby
@@ -182,7 +181,6 @@ liblrdf-devel
unixODBC-devel
gtk-doc
librsvg2-tools

libXv-devel
net-tools
libcap-devel

+ 25
- 0
redhat/tdelibs/tdelibs-3.5.13.2-fix_arts_include.patch View File

@@ -0,0 +1,25 @@
diff --git a/arts/kde/CMakeLists.txt b/arts/kde/CMakeLists.txt
index 3b58525..091be35 100644
--- a/arts/kde/CMakeLists.txt
+++ b/arts/kde/CMakeLists.txt
@@ -27,11 +27,6 @@ link_directories(
${ARTS_LIBRARY_DIRS}
)
-# pkg-config stripping -I/usr/include
-if( NOT ARTS_INCLUDE_DIRS )
- set( ARTS_INCLUDE_DIRS "/usr/include" )
-endif()
-
##### headers ###################################
@@ -58,7 +53,7 @@ set( ${target}_SRCS
add_custom_command(
OUTPUT artskde.cc artskde.h
COMMAND ${ARTS_MCOPIDL_EXECUTABLE}
- -I${ARTS_INCLUDE_DIRS} ${CMAKE_CURRENT_SOURCE_DIR}/artskde.idl
+ -I${ARTS_INCLUDEDIR} ${CMAKE_CURRENT_SOURCE_DIR}/artskde.idl
DEPENDS artskde.idl
)

+ 3
- 0
redhat/tdelibs/tdelibs-3.5.13.2.spec View File

@@ -38,6 +38,8 @@ Source0: %{name}-%{version}%{?preversion:~%{preversion}}.tar.gz
Patch1: tdelibs-3.5.13.2-fix_xdg_menu.patch
# Fix startup of KDE4 applications
Patch2: tdelibs-3.5.13.2-fix-starting-kde4-applications.patch
# Fix ARTS includes directory
Patch3: tdelibs-3.5.13.2-fix_arts_include.patch

# Patches from Mandriva
Patch101: tdelibs-3.5.13.2-xdg_dirs_set_path.patch
@@ -374,6 +376,7 @@ applications for TDE.
%setup -q -n %{name}-%{version}%{?preversion:~%{preversion}}
%patch1 -p1 -b .xdg
%patch2 -p1 -b .kde4
%patch3 -p1 -b .arts
%patch101 -p1 -b .xdg_path
%patch102 -p1 -b .cups_by_default



+ 33
- 1
redhat/tdemultimedia/tdemultimedia-3.5.13.2-ftbfs.patch View File

@@ -5,7 +5,39 @@
$(top_builddir)/arts/midi/libartsmidi_idl.la \
$(top_builddir)/arts/modules/synth/libartsmodulessynth.la \
- -lartsflow -lartsflow_idl -lmcop $(LIB_KDECORE) $(LIB_QT) $(VORBISFILE_LIBS) -lgthread-2.0
+ -lartsflow -lartsflow_idl -lmcop $(LIB_KDECORE) $(LIB_QT) $(VORBIS_LIBS) $(VORBISFILE_LIBS) -lgthread-2.0 -lmad
+ -lartsflow -lartsflow_idl -lmcop $(LIB_KDECORE) $(LIB_QT) -lgthread-2.0 $(ARTS_LIBS)
libartsmodulescommon_la_LDFLAGS = $(all_libraries) -L$(arts_libraries) -no-undefined
--- trinity-tdemultimedia-14.0.0~pre178+601a5c5f/arts/modules/synth/Makefile.am.ORI 2013-08-04 19:15:24.030530158 +0200
+++ trinity-tdemultimedia-14.0.0~pre178+601a5c5f/arts/modules/synth/Makefile.am 2013-08-04 19:15:32.878625492 +0200
@@ -31,7 +31,7 @@
libartsmodulessynth_la_LIBADD = \
$(top_builddir)/arts/runtime/libartsbuilder.la \
$(top_builddir)/arts/midi/libartsmidi_idl.la \
- -lartsflow -lartsgsl -lartsflow_idl -lmcop -lglib-2.0
+ -lartsflow -lartsgsl -lartsflow_idl -lmcop -lglib-2.0 $(ARTS_LIBS)
#libartsmodulessynth_la_LIBADD = $(top_builddir)/arts/gui/common/libartsgui_idl.la $(top_builddir)/arts/midi/libartsmidi_idl.la -lartsflow -lartsflow_idl -lmcop $(LIBDL) $(LIB_KDEUI) $(LIB_KDECORE)
libartsmodulessynth_la_LDFLAGS = $(all_libraries) -L$(arts_libraries) -lartsflow -lartsgsl -no-undefined
--- trinity-tdemultimedia-14.0.0~pre183+1859432c/configure.in.in.ORI 2013-09-08 17:50:11.453897325 +0200
+++ trinity-tdemultimedia-14.0.0~pre183+1859432c/configure.in.in 2013-09-08 17:54:24.503460785 +0200
@@ -544,15 +544,18 @@
LIB_ARTS="-lartskde"
ARTS_PREFIX=[`$ARTSCCONFIG --arts-prefix`]
ARTS_CFLAGS="-I$ARTS_PREFIX/include/arts"
+ ARTS_LIBS=[`$PKG_CONFIG --libs-only-l arts`]
AC_DEFINE(HAVE_ARTS, 1, [have arts support in juk])
else
build_arts="no"
LIB_ARTS=""
ARTS_CFLAGS=""
+ ARTS_LIBS=""
AC_DEFINE(HAVE_ARTS, 0, [no arts support in juk])
fi
AC_SUBST(LIB_ARTS)
AC_SUBST(ARTS_CFLAGS)
+AC_SUBST(ARTS_LIBS)
KDE_CHECK_MPEGLIB_ARTS

Loading…
Cancel
Save