#20 Remove old "minimum version of KDE is needed" messages.

Open
opened 3 months ago by Chris · 1 comments
Chris commented 3 months ago

Just to track that anywhere and to prevent it gets lost.

I will most likely do that.

That means:

“Reverse-resolving requires KDE version 3.5.1 or higher.” (from Konversation), for example.

It should be clear that this kind of messages are misleading and should be removed. TDE applications will only build against TQt and therefore TDE anyway, so this kind of messages are just confusing for users and there is no gain about them. Just noticed some of them while translating.

It is important to note, that this changes should be done also to translations with some “sed” or script, to prevent them to get “fuzzy”, which results in untranslated strings for users, while in reality the string is already translated and fine.

Some list will be maintained here, to show what components of TDE are already clean of that.

Check done for:

Main

  • tdeaccessibility
  • tdeaddons
  • tdeadmin
  • tdeartwork
  • tdebase
  • tdeedu
  • tdegames
  • tdegraphics
  • tdelibs
  • tdemultimedia
  • tdenetwork
  • tdepim
  • tdesdk
  • tdetoys
  • tdeutils
  • tdevelop
  • tdewebdev
  • applications

Applications

  • abakus
  • amarok
  • basket
  • bibletime
  • desktop-effects-tde
  • digikam
  • dolphin
  • filelight
  • gtk-qt-engine
  • gtk3-tqt-engine
  • gwenview
  • k3b
  • k9copy
  • kaffeine-mozilla
  • kaffeine
  • kasablanca
  • katapult
  • kbarcode
  • kbfx
  • kbibtex
  • kbiff
  • kbookreader
  • kchmviewer
  • kcmautostart
  • kcmldap
  • kcmldapcontroller
  • kcmldapmanager
  • kcpuload
  • kdbg
  • kdbusnotification
  • kdiff3
  • kdirstat
  • kdpkg
  • keep
  • kerberostray
  • kerry
  • keximdb
  • kftpgrabber
  • kgtk-qt3
  • kile
  • kima
  • kiosktool
  • kkbswitch
  • klcddimmer
  • kmplayer
  • kmyfirewall
  • kmymoney
  • knemo
  • knetload
  • knetstats
  • knetworkmanager8
  • knights
  • knmap
  • knowit
  • knutclient
  • koffice
  • konversation (WIP)
  • kooldock
  • kopete-otr
  • kpicosim
  • kpilot
  • kplayer
  • kpowersave
  • krecipes
  • krename
  • krusader
  • kscope
  • ksensors
  • kshowmail
  • kshutdown
  • ksplash-engine-moodin
  • ksquirrel
  • kstreamripper
  • ksystemlog
  • ktechlab
  • ktorrent
  • kvirc
  • kvkbd
  • kvpnc (WIP)
  • kxmleditor
  • mplayerthumbs
  • piklab
  • potracegui
  • qalculate-tde
  • qt4-tqt-theme-engine
  • rosegarden
  • smartcardauth
  • smb4k
  • soundkonverter
  • tastymenu
  • tde-guidance
  • tde-style-baghira
  • tde-style-domino
  • tde-style-ia-ora
  • tde-style-lipstik
  • tde-style-qtcurve
  • tde-systemsettings
  • tdedocker
  • tdeio-apt
  • tdeio-ftps
  • tdeio-gopher
  • tdeio-locate
  • tdeio-sword
  • tdeio-umountwrapper
  • tdenetworkmanager
  • tdepowersave
  • tderadio
  • tdesudo
  • tdesvn
  • tdmtheme
  • tellico
  • tork
  • twin-style-crystal
  • wlassistant
  • yakuake
Just to track that anywhere and to prevent it gets lost. I will most likely do that. ## That means: "Reverse-resolving requires KDE version 3.5.1 or higher." (from Konversation), for example. It should be clear that this kind of messages are misleading and should be removed. TDE applications will only build against TQt and therefore TDE anyway, so this kind of messages are just confusing for users and there is no gain about them. Just noticed some of them while translating. It is important to note, that this changes should be done also to translations with some “sed” or script, to prevent them to get “fuzzy”, which results in untranslated strings for users, while in reality the string is already translated and fine. Some list will be maintained here, to show what components of TDE are already clean of that. ## Check done for: ### Main - [ ] tdeaccessibility - [ ] tdeaddons - [ ] tdeadmin - [ ] tdeartwork - [ ] tdebase - [ ] tdeedu - [ ] tdegames - [ ] tdegraphics - [ ] tdelibs - [ ] tdemultimedia - [ ] tdenetwork - [ ] tdepim - [ ] tdesdk - [ ] tdetoys - [ ] tdeutils - [ ] tdevelop - [ ] tdewebdev - [ ] applications ### Applications - [ ] abakus - [ ] amarok - [ ] basket - [ ] bibletime - [ ] desktop-effects-tde - [ ] digikam - [ ] dolphin - [ ] filelight - [ ] gtk-qt-engine - [ ] gtk3-tqt-engine - [ ] gwenview - [ ] k3b - [ ] k9copy - [ ] kaffeine-mozilla - [ ] kaffeine - [ ] kasablanca - [ ] katapult - [ ] kbarcode - [ ] kbfx - [ ] kbibtex - [ ] kbiff - [ ] kbookreader - [ ] kchmviewer - [ ] kcmautostart - [ ] kcmldap - [ ] kcmldapcontroller - [ ] kcmldapmanager - [ ] kcpuload - [ ] kdbg - [ ] kdbusnotification - [ ] kdiff3 - [ ] kdirstat - [ ] kdpkg - [ ] keep - [ ] kerberostray - [ ] kerry - [ ] keximdb - [ ] kftpgrabber - [ ] kgtk-qt3 - [ ] kile - [ ] kima - [x] kiosktool - [ ] kkbswitch - [ ] klcddimmer - [ ] kmplayer - [ ] kmyfirewall - [ ] kmymoney - [ ] knemo - [ ] knetload - [ ] knetstats - [ ] knetworkmanager8 - [ ] knights - [ ] knmap - [ ] knowit - [ ] knutclient - [ ] koffice - [ ] konversation (WIP) - [ ] kooldock - [ ] kopete-otr - [ ] kpicosim - [ ] kpilot - [ ] kplayer - [ ] kpowersave - [ ] krecipes - [ ] krename - [ ] krusader - [ ] kscope - [ ] ksensors - [ ] kshowmail - [ ] kshutdown - [ ] ksplash-engine-moodin - [ ] ksquirrel - [ ] kstreamripper - [ ] ksystemlog - [ ] ktechlab - [ ] ktorrent - [ ] kvirc - [ ] kvkbd - [ ] kvpnc (WIP) - [ ] kxmleditor - [ ] mplayerthumbs - [ ] piklab - [ ] potracegui - [ ] qalculate-tde - [ ] qt4-tqt-theme-engine - [ ] rosegarden - [ ] smartcardauth - [ ] smb4k - [ ] soundkonverter - [ ] tastymenu - [ ] tde-guidance - [ ] tde-style-baghira - [ ] tde-style-domino - [ ] tde-style-ia-ora - [ ] tde-style-lipstik - [ ] tde-style-qtcurve - [ ] tde-systemsettings - [ ] tdedocker - [ ] tdeio-apt - [ ] tdeio-ftps - [ ] tdeio-gopher - [ ] tdeio-locate - [ ] tdeio-sword - [ ] tdeio-umountwrapper - [ ] tdenetworkmanager - [ ] tdepowersave - [ ] tderadio - [ ] tdesudo - [ ] tdesvn - [ ] tdmtheme - [ ] tellico - [ ] tork - [ ] twin-style-crystal - [ ] wlassistant - [ ] yakuake
MicheleC commented 3 months ago
Owner

Same for messages related to KDE1/2. I think here and there there are some references (perhaps now called TDE1/2)

Same for messages related to KDE1/2. I think here and there there are some references (perhaps now called TDE1/2)
Chris changed title from Remove old "minimum version of KDE3 is needed" messages. to Remove old "minimum version of KDE is needed" messages. 3 months ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.