Browse Source

Use poppler pkg-config information when running version checks

tags/r14.0.0
Timothy Pearson 7 years ago
parent
commit
03e9329656
1 changed files with 2 additions and 2 deletions
  1. +2
    -2
      kfile-plugins/dependencies/poppler-tqt/ConfigureChecks.cmake

+ 2
- 2
kfile-plugins/dependencies/poppler-tqt/ConfigureChecks.cmake View File

@@ -9,8 +9,8 @@ if( BUILD_KPDF )
endif( )

tde_save( CMAKE_REQUIRED_INCLUDES CMAKE_REQUIRED_LIBRARIES )
set( CMAKE_REQUIRED_INCLUDES ${DBUS_TQT_INCLUDE_DIRS} ${TQT_INCLUDE_DIRS} ${QT_INCLUDE_DIRS})
set( CMAKE_REQUIRED_LIBRARIES ${DBUS_TQT_LDFLAGS} ${TQT_LDFLAGS} ${QT_LDFLAGS} "-lpoppler" )
set( CMAKE_REQUIRED_INCLUDES ${DBUS_TQT_INCLUDE_DIRS} ${TQT_INCLUDE_DIRS} ${QT_INCLUDE_DIRS} ${POPPLER_INCLUDE_DIRS})
set( CMAKE_REQUIRED_LIBRARIES ${DBUS_TQT_LDFLAGS} ${TQT_LDFLAGS} ${QT_LDFLAGS} ${POPPLER_LDFLAGS} )
check_cxx_source_compiles("
#include <poppler/PSOutputDev.h>
int main(int, char**) { int a; int b; PSOutputDev *psOut = new PSOutputDev(\"test\", (PDFDoc*)0, (XRef*)0, (Catalog*)0, NULL, 0, 0, psModePS, a, b); } "


Loading…
Cancel
Save