#22 Add support for Poppler >= 0.82

Merged
SlavekB merged 2 commits from feat/poppler-082 into master 3 weeks ago
obache commented 1 month ago

Follow change that FontInfo::scan return a std::vector object rather than a pointer to a std::vector.

Signed-off-by: OBATA Akio obache@wizdas.com

Follow change that FontInfo::scan return a std::vector object rather than a pointer to a std::vector. Signed-off-by: OBATA Akio <obache@wizdas.com>
obache changed title from WIP: Add support for Poppler >= 8.82 to WIP: Add support for Poppler >= 0.82 1 month ago
obache commented 1 month ago
Poster

poppler<0.82 support may be broken.

poppler<0.82 support may be broken.
obache commented 1 month ago
Poster

Folow change “Make globalParams a std::unique_ptr” in poppler-0.83 additionally.

Folow change "Make globalParams a std::unique_ptr" in poppler-0.83 additionally.
MicheleC commented 3 weeks ago
Owner

Hi Obata-san. Is this PR ready to be merge or still WIP? is support for poppler <0.82 broken?

Hi Obata-san. Is this PR ready to be merge or still WIP? is support for poppler <0.82 broken?
obache commented 3 weeks ago
Poster

@MicheleC just not tested with <0.82, feedback is welcome!

@MicheleC just not tested with <0.82, feedback is welcome!
obache commented 3 weeks ago
Poster

I'm wondering if poppler-tqt should be external library.

I'm wondering if poppler-tqt should be external library.
SlavekB commented 3 weeks ago
Owner

@obache thank you, we'll do tests on older distributions.

@obache thank you, we'll do tests on older distributions.
SlavekB commented 3 weeks ago
Owner

Successfully tested on:

  • Debian 7.x (Wheezy) – poppler 0.18
  • Debian 9.x (Stretch) – poppler 0.48
  • Debian 10.x (Buster) - poppler 0.71
  • FreeBSD 12.1 – poppler 0.82

Everything seems to be all right and we can move forward.

Successfully tested on: * Debian 7.x (Wheezy) – poppler 0.18 * Debian 9.x (Stretch) – poppler 0.48 * Debian 10.x (Buster) - poppler 0.71 * FreeBSD 12.1 – poppler 0.82 Everything seems to be all right and we can move forward.
SlavekB changed title from WIP: Add support for Poppler >= 0.82 to Add support for Poppler >= 0.82 3 weeks ago
SlavekB deleted branch feat/poppler-082 3 weeks ago
SlavekB added this to the R14.0.8 release milestone 3 weeks ago
The pull request has been merged as 7e349b852e.
Sign in to join this conversation.
Loading…
Cancel
Save
There is no content yet.