Add support for Poppler >= 22.03. #45

Merged
SlavekB merged 1 commits from feat/poppler-22.03 into master 2 months ago
SlavekB commented 2 months ago
Owner

Build with patch for Poppler 22.03 successfully tested on ArchLinux.

Build with patch for Poppler 22.03 successfully tested on ArchLinux.
SlavekB added 1 commit 2 months ago
9adc0f647c
Add support for Poppler >= 22.03.
MicheleC approved these changes 2 months ago
MicheleC left a comment
Owner

Looks good.

Looks good.
Owner

Side note: we keep adding new lib version. Perhaps some of the very old versions are no longer provided by distros, so we could remove the check for those and simply make that part of the code as default?

Side note: we keep adding new lib version. Perhaps some of the very old versions are no longer provided by distros, so we could remove the check for those and simply make that part of the code as default?
SlavekB merged commit 9adc0f647c into master 2 months ago
SlavekB deleted branch feat/poppler-22.03 2 months ago
SlavekB added this to the R14.0.13 release milestone 2 months ago
Poster
Owner

Backport into R14.0.13 will be done after the new development window is open.

Backport into R14.0.13 will be done after the new development window is open.
Poster
Owner

Side note: we keep adding new lib version. Perhaps some of the very old versions are no longer provided by distros, so we could remove the check for those and simply make that part of the code as default?

Yes, surely, I also thought it was time to remove tests and code for supporting very old versions.

At the same time, I thought it was the time to move poppler-tqt directory from the tdefile-plugins/dependencies subdirectory to the tdegraphics main directory, because it is used as a standalone library, not just as an auxiliary dependence for tdefile-plugins.

> Side note: we keep adding new lib version. Perhaps some of the very old versions are no longer provided by distros, so we could remove the check for those and simply make that part of the code as default? Yes, surely, I also thought it was time to remove tests and code for supporting very old versions. At the same time, I thought it was the time to move `poppler-tqt` directory from the `tdefile-plugins/dependencies` subdirectory to the `tdegraphics` main directory, because it is used as a standalone library, not just as an auxiliary dependence for `tdefile-plugins`.

Reviewers

MicheleC approved these changes 2 months ago
The pull request has been merged as 9adc0f647c.
Sign in to join this conversation.
No reviewers
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This pull request currently doesn't have any dependencies.

Loading…
There is no content yet.