#35 device type in tooltip not updated when mounting/unmounting a disk

Closed
opened 2 months ago by MicheleC · 5 comments
  1. Setup system to display device icons on desktop and show tooltip.
  2. Check the status and tooltip value of a device (for example an unmounted disk).
  3. change the device state (unmount -> mount or viceversa)
  4. icon and space indication change accordingly, type in tooltip remains unchanged.

This can also be verified in Konqueror in system:/media.

Bug occourring in R14.0.7-DEV and R14.1.0-DEV

1. Setup system to display device icons on desktop and show tooltip. 2. Check the status and tooltip value of a device (for example an unmounted disk). 3. change the device state (unmount -> mount or viceversa) 4. icon and space indication change accordingly, type in tooltip remains unchanged. This can also be verified in Konqueror in system:/media. Bug occourring in R14.0.7-DEV and R14.1.0-DEV
MicheleC added the
SL/minor
label 2 months ago
MicheleC commented 1 month ago
Owner

The mime type of the medium is correctly updatedd when mounting/unmounting a disk. The problem comes from the KDirLister not propagating the changes to the respective views (konqueror/kdesktop) for media urls.

Here the url is not recognized as local. https://mirror.git.trinitydesktop.org/gitea/TDE/tdelibs/src/branch/master/tdeio/tdeio/kdirlister.cpp#L782

If adding conditions to check for media protocol items and enter the “if” block, here the search for a KFileItem fails https://mirror.git.trinitydesktop.org/gitea/TDE/tdelibs/src/branch/master/tdeio/tdeio/kdirlister.cpp#L785

It seems the correct way to fix this is to treat media:/ and system:/media urls as local and fix up the code accordingly where required (KUrl and KDirLister at least).

@SlavekB what’s your view on this?

The mime type of the medium is correctly updatedd when mounting/unmounting a disk. The problem comes from the KDirLister not propagating the changes to the respective views (konqueror/kdesktop) for media urls. Here the url is not recognized as local. https://mirror.git.trinitydesktop.org/gitea/TDE/tdelibs/src/branch/master/tdeio/tdeio/kdirlister.cpp#L782 If adding conditions to check for media protocol items and enter the "if" block, here the search for a KFileItem fails https://mirror.git.trinitydesktop.org/gitea/TDE/tdelibs/src/branch/master/tdeio/tdeio/kdirlister.cpp#L785 It seems the correct way to fix this is to treat media:/ and system:/media urls as local and fix up the code accordingly where required (KUrl and KDirLister at least). @SlavekB what's your view on this?
SlavekB commented 1 month ago
Owner

Good work! It seems that we have to find the reasons why the functions do not return the expected result. This may also fix some other problems that we haven’t noticed yet.

Good work! It seems that we have to find the reasons why the functions do not return the expected result. This may also fix some other problems that we haven't noticed yet.
MicheleC commented 1 month ago
Owner

I done some extra search. It is better not to consider a media:/ or system:/media url as local file, this could have unexpected consequences (like koffice trying to save it as a file…). Better to modify the KDirLister code to support media urls and restrict the scope and effects of the changes.

I done some extra search. It is better not to consider a media:/ or system:/media url as local file, this could have unexpected consequences (like koffice trying to save it as a file...). Better to modify the KDirLister code to support media urls and restrict the scope and effects of the changes.
MicheleC commented 1 month ago
Owner

I have done further investigation. The KDirLister is treating media urls as directories and ultimately most of the info gets correctly updated. Only the mime comment is not. So it looks this comment is not correct. I will continue to investigate further.

I have done further investigation. The KDirLister is treating media urls as directories and ultimately most of the info gets correctly updated. Only the mime comment is not. So it looks [this comment](https://mirror.git.trinitydesktop.org/gitea/TDE/tdelibs/issues/35#issuecomment-3929) is not correct. I will continue to investigate further.
MicheleC commented 1 month ago
Owner

Solved by PR #48 and TDE/tdebase#56

Solved by PR #48 and TDE/tdebase#56
SlavekB added this to the R14.0.7 release milestone 1 month ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.