TDE core libraries
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

configure.in.bot 4.8KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. dnl put here things which have to be done as very last part of configure
  2. if test "x$have_ssl" != xyes; then
  3. echo ""
  4. echo "You're missing openSSL, or your version is too old (before 0.9.5a)."
  5. echo "KDE won't be able to access secure websites without it, so you should"
  6. echo "consider installing or upgrading it."
  7. echo "Have a look at http://www.openssl.org, or find a binary package for"
  8. echo "your platform."
  9. echo ""
  10. all_tests=bad
  11. fi
  12. if test -z "$LIBART_CONFIG"; then
  13. echo ""
  14. echo "You're missing libART LGPL, or your version is too old (before 2.3.8)."
  15. echo "KDE won't be able to render SVG icons without it, so you should"
  16. echo "consider installing or upgrading it."
  17. echo "Have a look at http://www.levien.com (official site) or"
  18. echo "http://svg.kde.org/download.html for sources, or find a binary"
  19. echo "package for your platform."
  20. echo ""
  21. all_tests=bad
  22. fi
  23. if test -z "$LIBPCRE"; then
  24. echo ""
  25. echo "You're missing libpcre."
  26. echo "Some web pages (using regular expressions in Javascript code) will not "
  27. echo "work correctly, the regexp support being limited without libpcre. "
  28. echo "If you plan to use Konqueror as a Web Browser, download libpcre from "
  29. echo "http://www.pcre.org or find a binary package for your platform."
  30. echo ""
  31. all_tests=bad
  32. fi
  33. if test -z "$LIBBZ2"; then
  34. echo ""
  35. echo "You're missing bzip2 development files."
  36. echo "KDE won't be able to provide a help ioslave (help://) without it,"
  37. echo "so if you want helpfiles you should consider installing it."
  38. echo "Have a look at http://sources.redhat.com/bzip2/ for sources, "
  39. echo "or find a binary package for your platform."
  40. echo ""
  41. all_tests=bad
  42. fi
  43. if test -z "$LIBXML_CFLAGS"; then
  44. echo ""
  45. echo "You're missing libxml2 2.4.8 or later."
  46. echo "KDE won't be able to provide a help ioslave (help://) without it,"
  47. echo "so if you want helpfiles you should consider installing it."
  48. echo "Have a look at ftp://xmlsoft.org/ for sources, or find a binary"
  49. echo "package for your platform."
  50. echo "You can find a copy of libxml2 in the tdesupport module if you're using CVS."
  51. echo ""
  52. all_tests=bad
  53. fi
  54. if test -z "$LIBXSLT_CFLAGS"; then
  55. echo ""
  56. echo "You're missing libxslt 1.0.7 or later."
  57. echo "KDE won't be able to provide a help ioslave (help://) without it,"
  58. echo "so if you want helpfiles you should consider installing it."
  59. echo "Have a look at ftp://xmlsoft.org/ for sources, or find a binary"
  60. echo "package for your platform."
  61. echo "You can find a copy of libxslt in the tdesupport module if you're using CVS."
  62. echo ""
  63. all_tests=bad
  64. fi
  65. if test -z "$jpeg_incdir" || test -z "$LIBJPEG" ; then
  66. echo ""
  67. echo "You're missing libjpeg 6 or later."
  68. echo "KDE won't be able to display JPEG and many web pages won't"
  69. echo "work because of this."
  70. echo "You may need to either provide correct --with-extra-... options,"
  71. echo "or the development package of libjpeg6b. You can get a source "
  72. echo "package of libjpeg from http://www.ijg.org/"
  73. echo ""
  74. all_tests=bad
  75. fi
  76. if test "$kde_supports_versionmaps" != "yes"; then
  77. echo ""
  78. echo "Your ld doesn't support unversioned version scripts."
  79. echo "KDE will continue to build and run just fine, but you might"
  80. echo "experience a small performance penality."
  81. echo ""
  82. echo "If you're running Linux, your binutils are probably too old."
  83. echo "If you're running non-linux your platform might simply not support it."
  84. echo ""
  85. all_tests=bad
  86. fi
  87. if test "$ac_use_cups" != "yes"; then
  88. if test "$ac_have_new_cups" != "yes"; then
  89. echo ""
  90. echo "The installed CUPS version is too old. The minimum"
  91. echo "required version is 1.1.9. Please upgrade your CUPS"
  92. echo "installation from http://www.cups.org. CUPS support"
  93. echo "has been disabled."
  94. echo ""
  95. else
  96. echo ""
  97. echo "You're missing CUPS (Common UNIX Printing System) support."
  98. echo "If you want CUPS support, please install CUPS from http://www.cups.org"
  99. echo "or the development packages of your distribution."
  100. echo ""
  101. fi
  102. all_tests=bad
  103. fi
  104. if test "$EXRSTATUS" = "no"; then
  105. echo ""
  106. echo "No OpenEXR Libraries were found"
  107. echo "Install the OpenEXR package (from http://www.openexr.org)"
  108. echo "if you want EXR image format support"
  109. echo ""
  110. fi
  111. if test "$EXRSTATUS" = "old"; then
  112. echo ""
  113. echo "OpenEXR libraries were found, but at least version 1.1.0 is required"
  114. echo "Install a newer OpenEXR package (from http://www.openexr.org)"
  115. echo "if you want EXR image format support"
  116. echo ""
  117. fi
  118. if test "$USE_POSIX_ACL" != "yes"; then
  119. echo ""
  120. echo "libacl was not found. Without that library, you will not be able"
  121. echo "to manage access control lists on file systems that support them,"
  122. echo "such as ext3 or reiserfs."
  123. echo "You can download it from ftp://oss.sgi.com/projects/xfs/cmd_tars/"
  124. echo "(you will need attr too)"
  125. echo ""
  126. fi