#31 dm-plain encryption support does not work with fixed harddisk

Open
opened 5 months ago by MicheleC · 0 comments

TDE version: R14.1.0 dev

  1. install TDE on VM

  2. Create a luks disk on a brand new disk (see here). This steps is only required to make the disk visible to Konqueror (see #30)

  3. Overwrite previous step and create a dm-plain encrypted disk (see here).

  4. Try to open disk from konqueror: after entering the password an error is display about the disk not been removable

NOTE: if the disk is listed in /etc/pmount.allow, the disk is mountable. Would be good to find a solution that allows to mount the disk without requiring such change, if possible

TDE version: R14.1.0 dev 1. install TDE on VM 2. Create a luks disk on a brand new disk (see [here](https://www.linode.com/docs/security/encrypt-data-disk-with-dm-crypt/#how-to-use-dm-crypt-with-luks)). This steps is only required to make the disk visible to Konqueror (see #30) 2. Overwrite previous step and create a dm-plain encrypted disk (see [here](https://www.linode.com/docs/security/encrypt-data-disk-with-dm-crypt/#how-to-use-dm-crypt-in-plain-mode-without-luks)). 3. Try to open disk from konqueror: after entering the password an error is display about the disk not been removable NOTE: if the disk is listed in /etc/pmount.allow, the disk is mountable. Would be good to find a solution that allows to mount the disk without requiring such change, if possible
MicheleC added this to the R14.1.0 release milestone 5 months ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
Cancel
Save
There is no content yet.